Sending scheduled reports to email or file share not working

  • Hi all

    I have SQL 2005 report server on one box

    an email sever in another box

    When I tried to scheduled a report to send to my company email address, it failed to send

    Sending to a file share also failed.

    The error message states

    Failure writing file : The report server has encountered a configuration error. See the report server log files for more information.

    Having had a look at the report server log, there dont seem to be anything obvious, only the following

    The extension Report Server Email does not have a LocalizedNameAttribute.

    The extension Report Server FileShare does not have a LocalizedNameAttribute.

    Any help or suggestion appreciated



  • Hi Will,

    Did you configure the E-mail settings section in Sql Server Reporting Services Configuration tool...??

    B'coz it is mandatory to configure the E-mail Settings section with the SMTP address inside Configuration Settings.

    Please check, whether you have done the correct E-mail Settings there?

    Thanks alot,


  • Hi Niraj,

    Yes the email settings had been entered correctly. Although I am now getting the error message

    'Failure sending mail: The message could not be sent to the SMTP server. The transport error code was 0x800ccc15. The server response was not available '

    I have checked the internet to see what the error is and a possible solution but nothing came up.


  • Hi Will,

    This error either belongs to TCP/IP error or it may be a socket problem [SOCKET_CONNECT_ERROR]...

    I would advice you to check once again the SMTP address...



  • Hi Niraj,

    Thank you for your reply. I have managed to sort out the problem with sending reports out to users.

    For those that are in a similar position here is what I amended on our system

    The email configuration setting was set up properly but the problem was because our McAfee EPO was set to block all mass mailing worms from sending mail.

    To overcome this, I included the reportingServicesService.exe in the excluded list

    This solved one issue with sending email to include a link report but emailing the report as a excel or any other attachment failed.

    I then followed the article to allow me to send attached report to email users.


  • Gr8n news Will...n thank you for suggesting the perfect way to get the solution running....



  • Hi All,

    Try this:

    Go to 'Configuration Tools' -> 'Report Services Config. Manager' -> 'Service Account' -> 'Built-in Account' -> create a network service.

    (Having other types was what caused issues for me - I am using SQL Server 2008 R2.)

    Also 'Email settings' should be set properly in the Report Services Config. Manager.

    Now open the report in Internet Explorer, navigate to the right location and click on 'Subscriptions', click on 'New Subscription' and you should be able to pick "Email" since settings were established in the above step. (You can also choose to send to a folder.) Once a schedule is set on the same page, the report should be delivered at the said time.

    You can also check the error logs if something goes wrong.

    This is located at C->Program Files->MS SQL Server->MSRS10_50.MSSQLSERVER->LogFile



  • Hi Will,

    Can you please explain how did you include the reportingServicesService.exe in the excluded list as I am getting the same error and I confirmed that SMTP setting is appropriate.



  • Hi,

    Sorry for the late response.

    I went into the McAfee ePolicy Orchestrator 4.5.0 Console (this is the main server that deals with the antivirus). This maybe different depending on the version of EPO you are using but here is what I did.

    Click on policy catalog

    In policy catalog, Select viruscan enterprise 8.7.0 as the product (This should be the product that your company is using)

    Select Access Protection Policies in the category selection

    On the bottom pane you should see a Mcafee Deafault policy and maybe a policy called My default

    On the right of 'My Default' policy, there should be an Edit setting link, click on the Edit Setting link.

    This should take you to the Access Protection Page

    There should be a drop down list\box called Select setting (on mine it is defaulted to Workstation)

    Select setting for Server from the drop down list

    Select Anti-virus Standard protection from the Access Protection rules

    Highlight the 'Prevent Mass Mainling word from sending email'

    Select the edit button

    type in 'reportingServicesService.exe' into the process to exclude box and click ok

    click save to save your changes

    This is what I did to allow the SQL subscription to send the email to recipients.

    Please note also that whenever or whoever updates to the latest EPO (McAfee ePolicy Orchestrator), the setting that you place above will be lost and you need to redo adding the 'reportingServicesService.exe' to the exclude list again. This is what I find out when coming in one morning to be inundated from users saying that they had no emails about their reports. Turns out that one of the IT guys who deals with the updating of servers, anti-virus, etc updated the EPO whilst I was away.


  • We had the same issue and managed to solve it using the steps set out in

    We had to apply Method 2 and Method 3.

    We added the service account running the SQL Agent + Reporting Services to the Active Directory security group “Windows Authorization Access Group”, this allows those accounts to read all user properties in the domain, this is only applicable to domains running in Windows 2003 Native Mode. It’s basically just the steps in method 2 + 3 combined although the MS doc never mentions you need to do it on the Agent service account as well but it is indeed needed

  • I had the same issue that I needed to troubleshoot. In my case it was McAfee EPO which was blocking the ReportingServicesService.exe to relay emails to SMTP server. Adding the executable to exclusion list fixed my problem.

  • I am able send email form Sql server and able tp oing and telnet to smtp.when sechule ssrs report, it is not working it show following

    The extension Report Server Email does not have a LocalizedNameAttribute.

Viewing 12 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic. Login to reply