script task error after deploying to SQL Server 2019

  • I have an SSIS package that is failing on a Script Task with this error message.

    "Failed to migrate scripts contained in the package to the VSTA 15.0 format."

    This package was running fine on SQL Server 2012. But we recently upgraded to SQL Server 2019 and when I deploy this package to this new server, I get the above error message. This package is deployed from Visual Studio Professional 2015.

    Has anyone seen this error before. I Googled this error but the discussions I found are very confusing. Would someone be able to help me figure this out. Thank you in advance.

     

     

  • I suspect that you'll need to upgrade your VS version to match or exceed the SQL Server version (ie, 2019 or 2022).

    If you haven't even tried to resolve your issue, please don't expect the hard-working volunteers here to waste their time providing links to answers which you could easily have found yourself.

  • I believe that Phil is correct. When we updated from 2008 to 2019 I tried several versions of VS. For me VS 2016 was where I found our SSIS packages were most compatible with the least rewrites. Most scripts will need to be converted. For that create a new Script task\component copy and pasted the code, rebuild the package. Not to bad, we had 30 packages took about a week to get them all converted and tested.

    • This reply was modified 2 months, 1 week ago by  wburke 85918.
  • Open the package open the script and resave it, should be OK unless it was written in VB. If so you'll need to re-write it in C#. This was our experience.

    We migrated from 2016 and had a handful of scripts we needed to open and re-save. Not sure why some work and some dont. Maybe it depends on what .net namespaces are being used.

  • The script was written in VB so I'm afraid I can't try this. Thank you for your suggestion.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic. Login to reply