Scheduling SSIS Packages - SQL School Video

  • Comments posted to this topic are about the item Scheduling SSIS Packages - SQL School Video

  • Nice :):)

  • I got this message, does someone face this kinf of issue, I think I need more permission.

    Message

    Executed as user: ServerName\SYSTEM. ...n 9.00.3042.00 for 64-bit Copyright (C) Microsoft Corp 1984-2005. All rights reserved. Started: 9:54:31 AM Error: 2008-10-09 09:54:32.55 Code: 0xC0016016 Source: Description: Failed to decrypt protected XML node "DTS:Password" with error 0x8009000B "Key not valid for use in specified state.". You may not be authorized to access this information. This error occurs when there is a cryptographic error. Verify that the correct key is available. End Error Error: 2008-10-09 09:54:35.28 Code: 0xC0016016 Source: Description: Failed to decrypt protected XML node "PackagePassword" with error 0x8009000B "Key not valid for use in specified state.". You may not be authorized to access this information. This error occurs when there is a cryptographic error. Verify that the correct key is available. End Error Error: 2008-10-09 09:54:35.28 Code: 0xC0016016 Source: Description: Failed ... The package execution fa... The step failed.

  • This is a common problem where the job doesn't have the rights to run the package. The default property for a package is EncryptSensitivewithUserKey for the ProtectionLevel property. Ideally, you should set that to EncryptAllwithPassword and pass the password into the package.

  • Thanks for your soon answer Brian, I will do it and if I got an error I will let you know.

    Regards,

    Miguel

  • I got the same error and tried different options for protectionlevel but failed with same error.

    i tried serverproperty and dont save sensitive but still failed.

  • That resolved it for me but it really doesn't make sense why it works. Any clues? All I know is it's resolved and I'm ahppy

  • Thanks Brain that really helped.

  • thanks Brian, worked like a charm

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic. Login to reply