RS stopped working after change to rsreportserver.config!

  • There has to be a simple fix for this. All i did was change a config file and put the original back in place, not RS doesn't work! Specifically, before making a change (in notepad) to the report server file rsreportserver.config, I made a backup copy. I tested the change which caused RS to not work anymore, so I replaced the modified version with the backup file. RS won't work now! I restarted services and even rebooted, but it still doesn't work. Below are messages and errors from various log files.

     

    I'm using SQL Server 2005 (9.0.2047) on Windows XP sp2 (yeah, it's a workstation).It's worked for months with no problem. The original install was perfect. 

     

    ------------------------Error messages------------------------------

    When I go to http://localhost/reports/Pages/Folder.aspx the browser returns the error message...< ?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

     

    The report server cannot open a connection to the report server database. A connection to the database is required for all requests and processing. (rsReportServerDatabaseUnavailable) Get Online Help.

    An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

      

    The System Event Log shows...------------------------------------------

     

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {BA126AD1-2166-11D1-B1D0-00805FC1270E} to the user SERVER_NAME\ASPNET SID (S-1-5-21-1409082233-1563985344-682003330-1005). This security permission can be modified using the Component Services administrative tool.

     

    The Application Event Log shows...----------------------------------------

     

    Report Server Windows Service (MSSQLSERVER) cannot connect to the report server database.

     

    A RS log file contains the warning…--------------------------------------

     

    aspnet_wp!configmanager!5!12/16/2006-22:48:39:: w WARN: WebServiceAccount is not specified in the config file. Using default: SERVER_NAME\ASPNET.

     

     Any help would be very much appreciated. Thanks.

     

     

     


    smv929

  • Try going into Configuration Tools (under the Start menu, Microsoft SQL Server 2005), and using the Reporting Services Configuration.

    These tools should be granting the needed permissions as you make account changes.

    GE

  • The error indicates that your connection information to the report server database in the rsreportserver.config file has become corrupt.

    Please look at this article.

    http://msdn.microsoft.com/en-us/library/ms156468.aspx

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply