ReportingServicesNativeClient

  • Hi all,

    I've installed SQL Server 2008 , 64-bit, on my 64-bit windows 2008 computer. The installation went ok, However, when I try to access the Reports Manager at http://localhost/reports, I get the following error:

    Could not load file or assembly 'ReportingServicesNativeClient, Version=0.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. An attempt was made to load a program with an incorrect format.

    I'm sure it's a 64-bit problem but I don't know how to solve it. Any help would be appreciated.

  • I've got the same problem on a Windows Server 2008, I've tried also to install Service Pack 2 but the problem persists...

    I've found a solution telling about copying ReportingServicesNativeClient.dll in another folder but didn't work for me, if you want to give a look at it go to http://social.msdn.microsoft.com/Forums/en-US/sqlreportingservices/thread/c02ed0d3-9f12-41c1-898b-6de137839f70

    Greetings, Loris

  • The problem is not SSRS, the problem is asp runing on 32-64 bits. to enable the SSRS follow these steps:

    1. To run the 64-bit version of ASP.NET 2.0, Click Start, click Run, type cmd, and then click OK.

    2. Type the following command to disable the 32-bit mode:

    cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 0

    3. Type the following command to install the version of ASP.NET 2.0 and to install the script maps at the IIS root and under:

    %SYSTEMROOT%\Microsoft.NET\Framework64\v2.0.50727\aspnet_regiis.exe -i

    4. Make sure that the status of ASP.NET version 2.0.50727 is set to Allowed in the Web service extension list in Internet Information Services Manager.

    5. Check the SSRS configuration

    Note The build version of ASP.NET 2.0 may differ depending on what the currently released build version is. These steps are for build version 2.0.50727.

    view this link : http://support.microsoft.com/kb/894435/en-us

  • HI,

    I am having the same problem here with the BadImageException. The thing is, reporting service worked now for a year or so and out of nowhere it started to not work. I don't know if an installation of windows update may have messe dit up but now i have tried everythign and this is the only thing i haven't tried. I am using iis 7.0 and i don't know if this is the reason but I don't have the adsutil.vbs file. what should I do? Where should I get it?

    Thank you!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic. Login to reply