Report Parameters Wont Go Away

  • Reporting Services - Wondering if anybody else has noticed this problem.  I am authoring a new report in Visual Studio.Net and setting up some parameters so that the user can provide some filtering criteria.   First time thru when running report in Preview the parameters look fine at the top.  If I subsequently go back to the parameters tab in author mode and try to change them in any way (i.e. changing text of original parameter label, deleting the original parameter altogether, etc.), when running preview again nothing happens to the displayed criteria; it is the same as originally set up.    The only thing I can get to change is by adding new parameters, I can't seem to get rid of or change anything that has already been set up.


  • This was removed by the editor as SPAM

  • Having just started working with RS, I don't know how much help I can be, but have you tried saving after the change and then going to the preview pane?

  • Did try that, even getting out of the IDE entirely, then rebooting even, still can't get any parameters to go away on the preview even though the parameters tab in author mode shows none or completely different parameters.   I'm starting to suspect somthing like cacheing involved.


  • The report parameters and dataset parameters are two different animals.  When your dataset query or stored procedure has parameters in it a report parameter will be created.  But if you change your dataset or sp parameters it will not change the report parameter.  so what can happen is that you will end up with an orphan report parameter that will show up in the preview.  the easy fix is to remove your report parameters and then go to your data view and hit the refresh button.  this will recreate the report parameters associated with that data set.

    *information above is from a novice and just based on a limited experience with rs*

  • Thanks j.d.  I did as suggested to no avail.  I even cleared ALL the SQL out of dataset query (basic query, no SP), made sure there were no parameters under the 'Edit dataset' button,  clicked the dataset refresh fields button several times throughout, saved & exited the report & the .Net IDE, stood facing the east with my left finger upside my nose and scattered pixie dust, went back into the IDE and the report, and all the parameters are still there under preview.  Definitely some sort of funky cacheing going on.

    I am still running the pre-RTM version of the tool so I think I am going to bag this effort and re-install the RTM version to see if that takes care of things & will post the results but may not be today.  Thx for the responses however.




  • Have you tried looking in the RDL for the offending parameters and manually chopping them out?  It may destroy your report so save a backup copy.

    "I met Larry Niven at ConClave 27...AND I fixed his computer. How cool is that?"
    (Memoirs of a geek)

Viewing 7 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic. Login to reply