Report Builder connection issue

  • crazy_new

    SSCarpal Tunnel

    Points: 4804

    Hi Guys,

    I have just setup a new reporting server and configured SSRS. I can connect to the report server from my local browser, however when I try to connect using report builder I get the following error:

    Connection Failed
    Unable to connect to the server that is specified int the URL , "http://serverIP/reports". Make sure that the server is running, the URL is correct and you have permission to use the server.

    In my options i have set up - http://serverIP:80/Reports
    And I use the same user name and password that I use for RDP and connecting via my web browser. The user is a sys admin, and also has sysadmin rights in my SQL Server management studio.
    What am I doing wrong?

  • Thom A

    SSC Guru

    Points: 98216

    Do you have a firewall on the serve, which is blocking the connection?

    Thom~

    Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does.

  • crazy_new

    SSCarpal Tunnel

    Points: 4804

    This server is newly set up. I would assume all the default settings.

  • Thom A

    SSC Guru

    Points: 98216

    crazy_new - Thursday, July 27, 2017 8:38 AM

    This server is newly set up. I would assume all the default settings.

    Windows firewall is enabled by default. have you set it up to allow http connections?

    Thom~

    Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does.

  • crazy_new

    SSCarpal Tunnel

    Points: 4804

    I have opened port 80 on the firewall. Is there anything else I should open?

  • Thom A

    SSC Guru

    Points: 98216

    crazy_new - Thursday, July 27, 2017 8:45 AM

    I have opened port 80 on the firewall. Is there anything else I should open?

    For http access, no. But if you're making connections from anywhere else then only you will know what ports your using. For example, you might want to open port 1433 is your SQL instance is running on the default port.

    Personally, and I know I'm not the only one, I'm not a fan of Windows Firewall. All our servers have it switched off and use other software.

    Thom~

    Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does.

  • Sue_H

    SSC Guru

    Points: 89893

    It could just be the URL you are referencing for the Report Server. Try using:
    http://<servername>/reportserver

    You need to point to the report server, not report manager.

    Sue

  • crazy_new

    SSCarpal Tunnel

    Points: 4804

    I have switched off the firewall completely and I am still getting the same error.

  • crazy_new

    SSCarpal Tunnel

    Points: 4804

    I got the connection working. The iss was that i was using http://serverip/reports instead of http://serverip/reportserver.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic. Login to reply