Remote SQL Server connectivity issue.

  • pols

    SSC Eights!

    Points: 861

    Hi,

    I am trying to connect the defferent ip from SQL 2014 management studio. Its throwing the below error.

    a network related or instance specific error occurred while establishing a connection to sql server was not found or not accisiblle.verify that the instance name is correct and that SQL Server is coinfigured to allow remote connections.(provider:Named pipes provider,error:40-could not open a connection SQL Server) Microsoft SQL Server ,error:1326)

    I tried all resolutions like below:

    1. in sql configuration manager the network Protocol: TCP/IP is enabled.

    2. windows fiewall enabled.

    3.created new inboundrule added 1433 port

    4.restarted all the services

    I tried ping the ip. its connecting

    i tried telnet ipaddress 1433.. It is connecting.

    when tenet is working and connecting to ip address. then why i am not able to connect through management studio?

    Please help me to resolve this. Anything else i need to do?

    Thanks,

    Jo

  • Andrey

    Right there with Babe

    Points: 723

    I would try the following:

    1. from command prompt using sqlcmd; example :   sqlcmd -S [tcp:]sqlhost\instance -E    or sqlcmd -S [tcp:]sqlhost\instance -U username -P password
    2. from management studio using the following format "tcp:sqlhost\instance"
  • Phil Parkin

    SSC Guru

    Points: 244133

    Did you also run

    EXEC sp_configure 'remote access', 1

    GO

    RECONFIGURE ;

    GO

    If the answer to your question can be found with a brief Google search, please perform the search yourself, rather than expecting one of the SSC members to do it for you.

  • pols

    SSC Eights!

    Points: 861

    Thank you very much for your replies.

    while connecting the remote server ip in the management studio, in the options i selected TCP/IP and timeout period to '0'. Then it worked for me.

     

     

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic. Login to reply