question about server properties

  • We are running SQL 2000 SP1 on a 2000 server with SP2 installed. Several days ago we started experiencing a problem while trying to display the properties window of a server listed under a SQL Server Group. The properties window tries to come up and then goes away. We have other SQL 2000 servers and this does not happen when displaying those properties.

    Does anyone know why this would start happening and how to fix it. We have reapplied the SP1 and that did not fix it. It will happen either on the server or remotely, and now it happens all the time.

    Any help would be appreciated.

  • Never seen that. Maybe try unregister/reregister the server?


  • Thanks, I tried that and it does not work.

  • Have also had the exact same strange behavior with the exact same platform on one server that seemed to start suddenly. Also tried un and re-registering the server and no luck. Have several other servers that properties come up fine. I checked Microsoft Support and haven't seen anything. I've had to resort to using sp_dboption to check settings.

    "All your database are belong to me"

  • Haven't seen this either. A couple things.

    - On your workstation, one server does not work and others do?

    - On the affected server, can you view properties from other servers? Just not the local one?

    - What about other parts of EM?. Do they work?

    Steve Jones

  • In my situation, it is a client's database box on their VPN in the datacenter and this behavior is on the database server itself. Other elements of the EM work. Can't register it on my own workstation (or any other) for remote admin because of present firewall security policy. I usually Term Serv to that box or get on the console for the server.

    "All your database are belong to me"

  • quote:

    Haven't seen this either. A couple things.

    - On your workstation, one server does not work and others do? - On server(s) or workstation(s) doesn't matter.

    - On the affected server, can you view properties from other servers? Just not the local one? - Yes can view other servers just not the local one's properties.

    - What about other parts of EM?. Do they work? - Yes all other parts work. I can check the properties of databases, tables and anything else I want. Just not the server properties.

    Steve Jones

  • Interesting. This sounds like a bug in EM that was introduced by SP1. Haven't seen it and this is a guess. If reapplying SP1 doesn't fix it, I think you might have to call MS. My guess is that some setting that is available on the properties window is causing en exception.

    A few other things. Do the workstations have SP1? Can you connect via DMO and get the properties?

    Steve Jones

  • Next chapter:

    Tried installing SP2 on the problem box. The Server Properties window still appears for about a second then disappears.

    Have registered the problem server on another SQL Server EM on the LAN that has straight up SQL 2000 no Service Pack. The properties window for the problem server still disappears, while properties window for the other server comes up just fine.

    Checked via sp_configure what the settings would be on the box as compared to the other SQL Server box that does not have the problem. Both the problem box and the box without Service Pack have 4 processors. I didn't change any server properties on either box. They are new installations not in production yet. The only difference in the comparison of the sp_configure output between the two boxes is the affinity mask minimum value.

    Working server


    affinity mask0214748364700

    Problem server:

    affinity mask-2147483648214748364700

    Would that cause a problem with the properties window?

    Haven't yet called MS, but I suppose that's the next step.

    "All your database are belong to me"

  • Wouldn't think it causes a problems, but it may. If there was some out of bounds value, then maybe the window can't be constructed completely.

    I think this is an MS call.

    Steve Jones

  • Ok. Will put in a call and let you know what's up.


    "All your database are belong to me"

  • Please do.

    Steve Jones

  • I fixed my problem this morning. How was an option when running the setup again for sql. The advanced option will let you repair the registry. By selecting this option, we are now able to view the properties of the SQL server (remotely and locally).

    Thanks for your help.

  • You are welcome and thanks a bunch for the followup. Hopefully this will help someone else.

    Steve Jones

  • Hadn't had a chance to call MS. Tried bacz's suggestion and ran the advanced option registry repair. That seemed to fix the problem. Thanks, so much!!

    "All your database are belong to me"

Viewing 15 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic. Login to reply