Querystore bug(?), not showing data

  • My company where I worked recently upgraded to SQL Server 2022 Enterprise and Querystore started to behave odd (the problem was detected then anyway).

    If I start Querystore, and filter data, "last hour/last 12 hours" etc everything seems to work ok. But if I pick "custom" and manually specify date+time (even if it's the same as "last hour") it only displays one query in the graph-window. Just looks like I've executed only one query during the specified timeperiod. Really strange, anyone experienced anything similar?


  • Thanks for posting your issue and hopefully someone will answer soon.

    This is an automated bump to increase visibility of your question.

  • I attach a screenshot from Querystore, "overall resource consumption" in gridformat. Around the 5:th of may, we upgraded to enterprise version but querystore started to behave odd, as you can you see in columns "total log memory used" and others. "Total row count" is alot lower than it used to be. Ideas anyone what has happened?



    You must be logged in to view attached files.
  • Issue solved, Querystore - storage was too low, we increased the storage and things turned back to normal as far as I can tell.

Viewing 4 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply