Thank you very much for showing how to access sys.sql_logins. I was not aware of the needed role.
May I suggest a naming convention? (Yes, I know, it depends on taste, and taste differs, but still...)
I think we should call the tables something like mastersys.<tablename>, as in mastersys.sql_logins, mastersys.firewall_rules. That will make it easy to convert your existing old code (from on-prem), and make it easier for 3rd part tool-makers like sp_Blitz to provide code that works on Azure SQL Databases as well as other types of SQL Server.