Problem backuping up to Network Share

  • rummings

    SSCarpal Tunnel

    Points: 4575

    I have a two node Active\Active SQL Server 2005 Cluster. I am running three instances on each node. When I try to backup the DBs on the one instance on the second node... it fails with:

    =================

    "BACKUP DATABASE [database1] TO DISK = N'\\sqlclust..." failed with the following

    error: "The operating system returned the error '64(The specified network name is no longer available.)' while attempting 'FlushFileBuffers' on

    '\\clusterman\b$\Backup\Data\FARM2\database1\database1_backup_2010_07_20_072640_7339252.bak'.

    Possible failure reasons: Problems with the query, "ResultSet" property not set correctly, parameters

    not set correctly, or connection not established correctly.

    =================

    I moved the instance to the first node in the cluster and it runs successfully. All other instances back up to the same Network share with no issues. If I try to backup the DBs on the instance that fails to the Network Share to the local drive... it is successful.

    I have tried recreating the Maintenance Plan several times as well as removing the "Verify backup" option in the plan. I also have the memory set to Static amounts. I have increased the Instance memory, but it still fails.

    Any advice would be greatly appreciated!

    Charlie

  • S. Kusen

    SSChampion

    Points: 10874

    It sounds like a network connectivity issue with node 2. Unfortunately, it would be hard to guess at what the issue might be. It may be worth looping in some network folks to do a sniffer trace between node 2 and that backup network share.

    It's not a lot of info, but hopefully it will guide you in the right direction.

    Steve

  • rummings

    SSCarpal Tunnel

    Points: 4575

    Thank You Steve for the information. I actually tried setting a new Key vallue (Sess Timeout) in the Registry and gave it the value 600. It worked for a single DB in the Maintenance Plan. I am going to try the complete Backup Plan tonight. Thanks again for the reply!

  • mark johnson-159789

    SSC-Addicted

    Points: 416

    Where was this registry setting located? I am having a similiar issue on some of my dev servers.

    Thanks:-)

    Mark

    Mark Johnson
    MCP, MCTS Sql Server 2005,MCTS Sql Server 2008, OCP

  • Gregory Gentile

    SSC Journeyman

    Points: 92

    I had the same problem. This should correct it.

    It is located under:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

    Create a dword “SESSTIMEOUT” with a value of 360.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic. Login to reply