PowerBI - Unable to configure https

    • SQL Server 2019 on Windows Core 2019
    • New PowerBI installation
    • No current SSL or port 443 users

    Screenshot 2022-01-13 082005

    However, when I try to configure HTTPS in the Report Server Configuration Manager, I get the error:

    Screenshot 2022-01-13 082315

    Also not sure why the "url was unexpectedly reserved" :-/

    After this error, the following *has* been added to the "reportserver.config" file though:

    Screenshot 2022-01-13 082935

    And port 443 is flagged as in use but still there is no SSL:

    Screenshot 2022-01-13 083443

     

    Can anyone advise why the HTTP certificate binding is failing in this scenario?

    Thanks.

     

    Additional information: This always occurs when I try to enable HTTPS:

    Screenshot 2022-01-14 091744

    • This topic was modified 5 days, 4 hours ago by  Pete Bishop. Reason: Further detail added
  • Not really.

    Currently I have the following in PowerBI rsreportserver.config

    <URLReservations>
    <Application>
    <Name>ReportServerWebService</Name>
    <VirtualDirectory>ReportServer</VirtualDirectory>
    <URLs>
    <URL>
    <UrlString>https://+:443</UrlString>
    <AccountSid>....../AccountSid>
    <AccountName>NT SERVICE\PowerBIReportServer</AccountName>
    </URL>
    </URLs>
    </Application>
    <Application>
    <Name>ReportServerWebApp</Name>
    <VirtualDirectory>Reports</VirtualDirectory>
    <URLs>
    <URL>
    <UrlString>https://+:443</UrlString>
    <AccountSid>........</AccountSid>
    <AccountName>NT SERVICE\PowerBIReportServer</AccountName>
    </URL>
    </URLs>
    </Application>
    </URLReservations>
  • You may also try configure HTTP first and then switch to https

  • Hi Jo.

    HTTP works fine and I've configured all my reports, subscriptions, etc. without issue. It's only when trying to enable HTTPS that I hit a problem.

    I've also attached a screenshot to the original post for an Audit Failure which always coincides with trying to do this - which might point to a permissions issue?

    Thanks.

  • Looks like this was caused by an invalid certificate. No idea what was wrong with it but applying a newly-created certificate worked without issue.

Viewing 5 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic. Login to reply