No object exists with the ID 0

  • I am getting this generic message when running my SSIS package.  The error is happening as part of my Data flow task which is loading into a SQL Server table using an OLE DB destination object.  The process loads a portion of the records actually most of them around 54k but fails quite a few as well around 9K.  I have an Error output and logic to capture the error messages and place in an error log table I have created again a SQL server table.  The error is very generic and doesn't give me much clues as to what is causing it.  I am hoping someone has had the same error or maybe multiple folks and they can pinpoint or tell me what it could possibly mean so I can try to adjust my package to deal with this.

    So the clues I have is:

    1. It happens in Data flow Task
    2. Specifically on the load into the SQL Server table using a OLE DB Destination object and OLE DB connector.
    3. Error message 'No object exists with the ID 0'

    Capture

    Please help!

    Mark

  • Errors which happen as data is loaded into a physical table often result in unhelpful error messages in SSIS.

    As a first step, I would try to determine one or more data rows which are causing the error.

    Once you have that, compare them with rows which load successfully and look for any patterns, bearing in mind any constraints on the target table (NOT NULL columns, unique indexes, CHECK constraints etc.) which may be causing the failures.

    Also, take a closer look at the error messages (if you're in SSDT) or at the All Executions report (if running from SSISDB), just in case there is any more detail hidden there.

    If you haven't even tried to resolve your issue, please don't expect the hard-working volunteers here to waste their time providing links to answers which you could easily have found yourself.

  • Thanks Phil, This is inline with what I was thinking to do, I was hoping for an easy way but at least this confirms my approach is sound.

    Cheers,

    Mark

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply