Native Error 29006, The process could not deliver the snapshot to the Subscriber

  • Rod Early

    Old Hand

    Points: 346

    I have a CF.NET application (C#) with a SqlCE database.  We had

    originally planned to use SQL Authentication to replicate with the

    publication and indeed had SQL Authentication working flawlessly.  Then

    our client asked us to use Windows Authentication instead.

    For incremental changes, Windows authentication works fine.  When

    trying to do the initial synchronization where the application receives

    the snapshot database from the publishing database, there is trouble.

    I have tested this in the PPC 2002 and 2003 emulators and on an

    actually PPC device as well.  I get the following error:

    A call to SQL Server Reconciler failed. [,,,,,],

    Source=Microsoft SQL Server 2000 Windows CE Edition,

    NativeError=29006,HResult=-2147467259

    The process could not deliver the snapshot to the Subscriber.,

    Source=Merge Replication Provider,

    NativeError=0,HResult=-2147201001

    Here is difference in my code between Windows and SQL Authentication:

    #if SQLAUTHENTICATION

                            repl.PublisherLogin = "MyLogin"; // publisher Login;

                            repl.PublisherPassword = "MyPassword"; // publisher Password;

                            repl.PublisherSecurityMode =

    System.Data.SqlServerCe.SecurityType.DBAuthentication;

    #else

                            repl.PublisherSecurityMode =

    System.Data.SqlServerCe.SecurityType.NTAuthentication;

    #endif

    As far as I know, I have properly configured the snapshot IIS folder

    with the correct permissions for IIS_MachineName (for anonymous-Sql

    Authentication) and also with the domain users for Windows

    Authentication.  The domain users are also in the Publication Access

    List.

    The bottom line is that in for Windows Authentication I am not able to

    receive the snapshot from the publishing database on the first

    synchronization.  However, I am able to do incremental synchronization

    through Windows Authentication.  And I have no problems with SQL

    Authenication (via the anonymous user).

    I am stumped by the "process could not deliver the snapshot to the

    Subscriber" error.  Have any of you encountered this situation before,

    and if so, how did you resolve it?

    Thanks,

    Rod Early

  • This was removed by the editor as SPAM

  • Connie Poon

    SSC Veteran

    Points: 266

    Not sure if it could help.

    Accord to SQLCE BOL - tried to verify that the user get read permission for the table...

    http://msdn.microsoft.com/library/default.asp?url=/library/en-us/sqlce/htm/_lce_troubleshooting_security_problems.asp

     

     

  • jonny.barnstorf

    SSC Enthusiast

    Points: 100

    I had the same problem:

    The snapshot location was incorrectly set in the replication properties

    the Replication wizard defaults the snapshot directory to something like:

    \\ServerName\C$\Program Files\Microsoft SQL Server\MSSQL\ReplData

    If you have specified a different directory you will need to set the properties to something like:

    \\ServerName\SnapShotDirectory

    in Enterprise Manager (EM) you would find this under

    -Tools -Replication -Configure Publishing...

    select the [Publishers Tab]

    select the [...] elipsis of the distrubtion db and set the snapshot folder in there.

    That's what worked for me 🙂

  • Rajesh Patil

    SSC Veteran

    Points: 219

    The Problem is not with the code its with the security settings of the reconciler dll location that you have on the desktop computer. try to check those setttings that might solve your problem. sorry to respond late and vague. Its been long time I tried out replication on handheld devices.

    Regards,

    Rajesh.

    MBA-IT (Software Dev & Mgmt)

    SCIT- 2007-09

  • rchavez

    SSC Enthusiast

    Points: 100

    Hi, if you solve the probem please tell me how I have the same problem.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic. Login to reply