MSDTC keeps stopping

  • We have a problem on one of our servers where by MSDTC keeps stopping unexpectidly usually during the night.

    The Windows event log has the following error, but I can't find anything on google


    The MS DTC Transaction Manager is in an inconsistent state and cannot proceed. Please contact Microsoft Product Support. (null)

    File: .\tmtx.cpp, Line: 2570.


    Any help appreciated.

    Thanks Jeet

  • What machine is it?

    Does it has all patches?

    Did occur it suddenly? If so any clue what has changed? (network, new machines...)

  • Is it happening every night, or ?? At the same time ???

    There is nothing in the system log ??

    Does any program stop due to backup at the same time ??

  • We are Running sql server 2000 (version 8.00.2039, SP4) on a windows server 2000 machine.

    This box has not changed at all, and there are no network changes that I am aware of. It started about 3 weeks ago and happens every few days.



    Thanks Jeet

  • Hello

    We do have the same Problem.

    We think it might have something to do with one of the october microsoft security updates.

    But we are still looking for a solution.



    Regards Andreas

    Regards Andreas Rullmann

  • Hi, solution looks to be this MS patch:

    good luck.

  • Did you ever get this resolved?

    We are experiencing the same effect here.

  • Same here. Anybody could resolve this?

    Otherwise we'll uninstall the security-patch regarding MSDTC..

  • Hi,

    we are having the same problem couple of times. Did anyone manage to get rid of it? Or did unistalling the security patch solved the problem?

  • Microsoft has a KB article for this error message.

    As per KB

    This problem occurs after you install the cumulative security update that is referenced in the following Microsoft Knowledge Base article:

    902400 ( MS05-051: Vulnerabilities in MS DTC and COM+ could allow remote code execution


    => You can call Microsoft PSS and get hotfix.

  • Uninstalling the security patch solved the problem..

Viewing 11 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic. Login to reply