Microsoft.SqlServer.Management.Sdk.Sfc not found

  • thomas.pluempe

    SSC Enthusiast

    Points: 183

    Hello,

    when attempting to add a database to my application in Visual Web Developer 2005 Express Edition, I get a successful connection to the Microsoft SQL Server and the browser shows my databases, I have created. But when I click 'OK' I get the message:

    "Can not add the database, because the file or Assembly "Microsoft.SqlServer.Management.Sdk.Sfc" can not be found."

    What can I do?

    Thomas

  • carlosalbertomurillo

    SSC Rookie

    Points: 33

    I had the same problem, this is because the uninstall did poorly done. I did that and it worked, tries to see if it fixes the problem:

    1. Download the Microsoft SQL Server 2008 Management Objects in the following URL:

    http://go.microsoft.com/fwlink/?LinkId=123708&clcid=0x409

    2. Install it in the machine

    3. Restart Visual Web Developer

    Maybe You also have to download the CLR types

    http://download.microsoft.com/download/d/a/a/daa0e7aa-b46f-4e01-ae4a-981f2aa314d5/instructions_esn.htm (its in spanish)

  • rtbala

    SSC Journeyman

    Points: 89

    thanks, it solved my problem.

  • moonfly.msk

    SSC Rookie

    Points: 47

    Thanks, it solved this problem for me as well.

    The easiest location to download both the CLR types and management objects is http://www.microsoft.com/downloads/details.aspx?FamilyId=228DE03F-3B5A-428A-923F-58A033D316E1&displaylang=en

  • Philip Hurzeler

    SSC Enthusiast

    Points: 176

    Worked for me too, thanks! Gotta scroll down pretty far to find those CLR types. Phil

  • bbandelin2

    Valued Member

    Points: 58

    I had this same issue. The solution above did the trick. Thanks!

  • yoel.masih

    SSC Journeyman

    Points: 85

    Been struggling with this issue for the past few days and found this post most valuable, thanks for it.

  • shr.prdhn

    SSC Rookie

    Points: 37

    Hey...:-)

    carlosalbertomurillo & moonfly.msk

    Thanks.... It worked...!!!

  • kmking

    SSC Journeyman

    Points: 95

    This solution ended a 3 hour search. Thank you for posting it.

  • Bill Wehnert

    Ten Centuries

    Points: 1057

    SQL Server Central for the WIN!

    I just migrated a 2008 project to 2010 and all sorts of stuff just broke. Couldn't find half of the DLLs - saved the day!

    Ad maiorem Dei gloriam

  • mascheck55

    Grasshopper

    Points: 15

    Thanks! it worked for me as well - some years after the first notice this failure still persists!

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic. Login to reply