Memory leak + destroy sqlCe objects

  • I developed an application using SqlCe2.0. My application has exception when using SqlCeDataAdapter.Fill(...) method when it is used for many many times. The error is "Not enough storage is available to complete this operation...". I am quite sure I dispose those "SqlCeDataAdapter, SqlCeCommand, SqlCeDataReader, SqlCeTransaction" objects in the finally block.

    By the way, I tried the hot fix "SSCE20.dll" from MS, but it still doesn't fix it.

    Does anybody know what should I do to fix this?

    Big thanks here!!!

  • This was removed by the editor as SPAM

  • Just shooting in the dark here, but have you checked the file size of your data file?  There is a finite limit on the file size of SSCE, and you can get unexpected results when you hit that limit.



    Tim Mitchell, Microsoft Data Platform MVP
    Data Warehouse and ETL Consultant | @Tim_Mitchell |
    ETL Best Practices

  • Thank you Tim.

    I will check my file size.

    My file won't be too big, normally less than 1M because every time one record is submitted to server, it will be deleted from the local device and the application always compact the local database file when it's size is bigger than 200k.

Viewing 4 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply