Login failed for user 'NT Service\MSSQLServerOLAPService' 28000

  • david 80723

    SSC-Addicted

    Points: 475

    I am using SQL Server 2012 developer edition on Windows 7. I have the following error attempting to process a dimension: OLE DB error: OLE DB or ODBC error: Login failed for user 'NT Service\MSSQLServerOLAPService' 28000

    I am new to SSAS and I have researched this thoroughly but still having trouble and don't have a lot of knowledge of all the different types of accounts.

    Thank you very much!

  • Jayanth_Kurup

    SSC-Insane

    Points: 22967

    Are you trying to process the cube remotely?

    Jayanth Kurup[/url]

  • david 80723

    SSC-Addicted

    Points: 475

    Thank you for your help. No, I'm not trying to access the cube remotely. This is a brand new SQL Server 2012 developer edition install with the default accounts on a laptop. The error occurred when I tried to process a dimension I created. I've done a lot of Google searches trying to get an answer and this article on the link below seemed to be the most relevant information:

    http://support.microsoft.com/kb/224973

    By changing the MSSQLServerOLAPService service to run under a domain or local user account that is a member of the OLAP Administrators group on the OLAP server and that has privileges on SQL Server, OLAP Services will be able to successfully process.

    My settings are: In my SQL Server Configuration Manager>SQL Server Analysis Services>Properties>Log On As>This account: NT Service\MSSQLServerOLAPService [with a default password supplied during the install]

    I don't know if the accounts are correct or how to find the OLAP Administrators group on the OLAP server in a Windows 7 environment. I am very new to SSAS.

    Thank you!

  • david 80723

    SSC-Addicted

    Points: 475

    SOLUTION FOUND

    I found the answer here on the MS SQL Server Forum for Analysis Services:

    Solution for: OLE DB or ODBC error:Login failed for user NT Service\MSSQLServerOLAPService error - create new login in the SQL Server database engine so analysis services can read the data in the database being analyzed.

    Create login and grant access:

    Open up SQL Server Management Studio [login to the database engine]>

    Security >

    Login (Right? click) >

    New Login >add user: "NT Service\MSSQLServerOLAPService">

    select the database being analyzed in the drop-down list at the bottom >

    User Mapping [click on the database in the list] >

    In the window database role membership click on db_datareader [this grants access to read the data]

    More details here http://msdn.microsoft.com/en-us/library/ms189751.aspx

    Hope this helps!

    Shahfaisal Muhammed http://shahfaisalmuhammed.blogspot.com

    http://shahfaisalmuhammed.blogspot.com/2012/09/login-failed-for-mssqlserverolapservice.html

    Thank you everyone who helped me - thank you very much!

  • SQLUserC

    SSCrazy

    Points: 2345

    Thanks for the info, I was having trouble with this as well.

  • careisin

    SSC Rookie

    Points: 45

    Oh my gosh I'm so glad you posted this. I've been struggling for hours and this was exactly the thing that fixed it. Thanks

  • cxulz

    SSC Journeyman

    Points: 94

    I have found another solution to the problem. Please see:

    http://sqlserverandme.blogspot.com/2013/04/a-solution-for-ssas-deployment-error.html

  • rohitc 87397

    SSC Enthusiast

    Points: 168

    You can also find the Windows Service (services.msc) and change the login account to one that already has access to your DB.

  • sqlcentral2@mailinator.com

    Ten Centuries

    Points: 1374

    Thanks, adding read right to SQLServerMSASUser$computer_name$instance_name solved the problem!

  • Ike Ellis

    SSC Journeyman

    Points: 79

    Yep, worked for me.

  • shane.tohill

    SSC Journeyman

    Points: 89

    Thanks, This solution has worked for me.

  • SQL Rich

    Valued Member

    Points: 61

    Thanks worked well.

  • rockstar283

    SSCrazy

    Points: 2704

    Your solution worked for me.. Thanks a lot 🙂

  • dimitrov

    Valued Member

    Points: 73

    Almost one year later, the solution provided is still good. I scoured the Internet looking for this solution and was so glad that you good folks have solved it. Thank you.

  • BI Consultent

    Grasshopper

    Points: 19

    Thank you so much it works me too:-)

Viewing 15 posts - 1 through 15 (of 23 total)

You must be logged in to reply to this topic. Login to reply