Log shipping performing log backups despite its backup jobs being disabled

  • Hi

    Came across an odd issue this evening. Running a migration over the weekend that required log shipping backup jobs to be disabled, databases moved to another server, then backed up and moved back.

    I noticed when moving things back that there are log backups in the folders for the duration of the time the jobs were disabled, and if I go to the Job History, sure enough, the jobs appear to have run every 15 minutes as they normally would.

    It's late here so I could be missing something simple, but is there something else I should have done in addition to disabling the Agent Jobs in the GUI?

    Many thanks in advance

    Alex.

     

    **Edit - Found the answer this morning.

    • This topic was modified 1 month ago by  alexhdavies.
  • Thanks for posting your issue and hopefully someone will answer soon.

    This is an automated bump to increase visibility of your question.

  • Glad you found the answer.  Could you share it with the group?

    I know I have not seen this issue before.  Generally though, I have a different habit.  I disable the schedule and create a new schedule for the job. The reason being that if I forget to turn the old schedule back on, the job will kick off again the next day.  This is especially helpful if I am doing "middle of the night" work where I may not be fully awake or if it is a process where I am likely to be interrupted.

  • Though I guess you would then need to backup the secondary's log to keep it No, you cannot set the log shipping job to do copy only log backups. I've disabled them, but LSAlert raises errors since the databases being I want to know how much logshipping Jobs (Backup, Copy, Restore) affects server's performance.

     

     

    paycheckrecords

    • This reply was modified 3 weeks, 3 days ago by  Richard248.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic. Login to reply