Why several different terms for the same thing (Intersection, Inner Join) ? I see this everywhere. Seems to me that multiple terms leads to multiple chances to miscommunicate, which I consider to be a major problem when dealing with programmers or managers.
Intersection is the theory of sets. When I have two sets, the overlapping members have an intersection. The terminology for the programming is inner join. However, what is an inner join? It's the intersection.