Intermitant Backup error

  • Catrina Bradford-281110

    Old Hand

    Points: 304

    Run backups to a repository server with 3 strips, stats 30

    BACKUP DATABASE [SERVER NAME]TO [DEVICE NAME], [DEVICE NAME], [DEVICE NAME] WITH INIT, STATS = 30

    30 percent backed up.

    60 percent backed up.

    Msg 3202, Level 16, State 0, Server [SERVER NAME], Line 913

    Write on [DEVICE NAME] failed, status = 121. See the SQL Server error log for more details.

    Msg 3013, Level 16, State 1, Server “SERVER NAME”, Line 913

    BACKUP DATABASE is terminating abnormally.

    This fails on one strip and on a different strip each night

    Have deleted devices and recreated

    Have dumped to a different server

    :exclamation:

  • free_mascot

    One Orange Chip

    Points: 27077

    What is the database size? Make sure you do have enough space for the backup. Generally once backup starts will completed successfully.

    ---------------------------------------------------
    "Thare are only 10 types of people in the world:
    Those who understand binary, and those who don't."

  • Chandra Sekhara Vyas Dhara

    SSChampion

    Points: 10207

    Check the following link

    http://forums.databasejournal.com/archive/index.php/t-16770.html

  • Catrina Bradford-281110

    Old Hand

    Points: 304

    It is only 10GB and there is plenty of space it gets to approx 80-90% finished and then fails over

  • free_mascot

    One Orange Chip

    Points: 27077

    While running backup execute sp_who2 active for any blocking and deeply monitor server activity from which you may get some clue. Also check sql server and window error log if you can find more details

    ---------------------------------------------------
    "Thare are only 10 types of people in the world:
    Those who understand binary, and those who don't."

  • Catrina Bradford-281110

    Old Hand

    Points: 304

    Sorry not the same error

  • Catrina Bradford-281110

    Old Hand

    Points: 304

    Database backed up: Database:DBName, creation date(time): 2006/06/09(10:41:53), pages dumped: 1421098, first LSN: 110597:15214:2, last LSN: 110597:15725:1, number of dump devices: 4, device information: (FILE=1, TYPE=DISK: {‘Z:\…..\…..\DUMPNAME1.DAT’, ‘Z:\…..\…..\DUMPNAME2.DAT’, ‘Z:\…..\…..\DUMPNAME3.DAT’, ‘Z:\…..\…..\DUMPNAME4.DAT’}).

    BackupMedium::ReportIoError: write failure on backup device ‘Z:\…..\…..\DUMPNAME4.DAT’. Operating system error 59(An unexpected network error occurred.).

    Internal I/O request 0x07DE5A10: Op: Write, pBuffer: 0x08AE0000, Size: 131072, Position: 1722489344, UMS: Internal: 0x0, InternalHigh: 0x20000, Offset: 0x66AB1A00, OffsetHigh: 0x0, m_buf: 0x08AE0000, m_len: 131072, m_actualBytes: 0, m_errcode: 59, BackupFile: Z:\…..\…..\DUMPNAME4.DAT

    BACKUP failed to complete the command BACKUP DATABASE DBName

  • KenpoDBA

    SSCrazy Eights

    Points: 9801

    What happens if you don’t stripe the backups? And it’s only 10GB, why do you need to stripe it to begin with?

    Watch my free SQL Server Tutorials at:
    http://MidnightDBA.com
    Blog Author of:
    DBA Rant – http://www.MidnightDBA.com/DBARant

    Minion Maintenance is FREE:

  • Steve Jones – SSC Editor

    SSC Guru

    Points: 713651

    Are these all on local drives? Or are some network?

  • Ian Yates

    SSCoach

    Points: 19678

    Are you seeing anything extra in the SQL Server log?

  • Ray Mond

    SSCertifiable

    Points: 7099

    It would appear that you are backing up to a remote drive. I would suggest backing up to a local drive first, and see if that completes successfully.

    SQL BAK Explorer - read SQL Server backup file details without SQL Server.
    Supports backup files created with SQL Server 2005 up to SQL Server 2017.

  • jdgonzalez@jdandrachel.com

    Hall of Fame

    Points: 3161

    I would suggest looking at the logs on the server you’re backing up to and also determine if there were any network issues at that time. Also, were there any other failures during this particular time on any other servers?

  • Joe Clifford

    SSCrazy Eights

    Points: 8689

    A couple of thoughts/points to explore as your backup is failing with “unexpected network error occurred” which can be caused by a wide variety of issues:

    (1) Other network activity at the time that you’re trying to take your backup. It’s possible that your “unexpected network error occurred” is really a timeout – what else is going on at the time you’re attempting your backup?

    (2) System activity unrelated to network activity – once upon a time I ran into a server that had been schedule to reboot every evening at 10:15 PM – is your target available?

    (3) Somewhat related to #1 it’s entirely possible that your network just can’t handle keeping a connection open long enough to complete the operation. It’s not unusual to encounter a network that just can’t handle operations that take more than X seconds to complete… you may simply have a network that drops connections/packets at a level that is typically acceptable for most applications but not for yours.

    Joe

  • andre.deslauriers

    SSC Veteran

    Points: 278

    Open the registry of the SQL Server machine and navigate to HKLM\System\CurrentControlSet\Services\lanmanworkstation\parameters

    Create a new DWORD value named SessTimeout

    Set the value to decimal 600 (hex 0x258)

    This corrected the problem for me.

    600 = 10 minutes

    Andre

  • b_boy

    SSCertifiable

    Points: 5085

    There is a possibility of the backup job running concurrently with another process, I’ll suggest you use filemon or ProcessMonitor, to find out what process is obstructing the backup.

    There is the possibilty that when the backup starts, it needs to acces a file which in turn is been used by another process which you will find out with those third party applications.

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic. Login to reply