Installing SP2 on a 4 way Active Cluster

  • I'm going to say this up front because it will become very obvious.  I inherited this cluster, and have little experience with them, so please bear with me.

    I am trying to install SP2 on a 4 node cluster where there is an Active instance on each node.  I've currently tried two different things, and had the following issues.

    1. I logged into the first node.  (Not the virtual insance)

    When I ran the Install is quit almost immediately because it detected the 3 extra passive instances.  Obviously when I logged into the next node, I had the same results just with different passive instances.

    2. To fix the issue with passive nodes, I failed all 4 instances over to the same node.  I figured that way there wouldn't be any passive nodes.  Yeah, I made it though the that step and it started to run the install.  However it quickly failed again giving me the following output in the Hotfix log file  (The following is repeated for each node):

    Task Scheduler: Created remote folder for product instance target \\SQL2
    Task Scheduler: Transferred payload to remote product instance target \\SQL2
    Task Scheduler: Created new scheduled task for product instance target \\SQL2
    Task Scheduler: Error, cannot save new scheduled task for product instance target \\SQL2
    Task Scheduler: Error, cannot create scheduled task for product instance target \\SQL2
    Task Scheduler: Removed remote folder for product instance target \\SQL2
    Error, remote process failed for product instance target
    Exit code for passive node: SQL2 = 1603

    Then I have the following entries for the final eror message:

    The following exception occurred: No passive nodes were successfully patched Date: <datehere>

    Am I just simply logging into the wrong place?  Should I be logging into the virtual instance as opposed to the Node?  Or is there something else that may be causing my issues.  Thanks for any assistance you can provide.


    wayne

  • were the other nodes up and reachable over the network? i've found that with clusters all nodes need to be up even if you fail everything to one node

  • Yes.  I could get to all of the other nodes in the cluster.  The machines were still hot even though nothing was actively running on them.


    wayne

  • 1st Check cluster log for any errors, ensure all nodes can communicate with each other.

    Logon to server 1 and run the setup and choose instance A and apply the sp on that instance(This updates all nodes that are members of that cluster). Failover instance A to server 2, reboot server 1. Failback instance A to server 1. Logon to Server 2, run the setup and choose instance B, apply the service pack, failover instance B to server 1, reboot server 2. Failback instance B to server 2. Move onto to do the same with sever 3 and 4.

    IF, you can run all instances from the same server at the same time, then you could get away with a quicker, easier update by appling the sp to all instances from the same server.

    Email me if I can help any further: iain@firmbyte.com

  • I'm not sure whether it's still an issue with Win2003 and SQL2005, but I ran into a problem a few years ago with installing a SQL2000 service pack because I was logged on the passive node at the same time I was installing the SP on the active node.  As I recall, it turned out to be a bug with the task scheduler.  Logging off the other node solved the problem for me.


    Regards,

    Todd Clark

  • Iain, Thank you for the information.  I'll be sure to post back if I run into any issues, and contact if I really hit a wall.

    Todd, That could very well be what happened.  I'll have to try again.  I am pretty sure I was logged into all 4 of the nodes when I was doing this.  It's possible that they've fixed your issue and this is something else, but it sounds very possible.  Thanks for the insight.


    wayne

  • I have run into this issue also and have not come up with a fix. I spent most of the day yesterday searching for solutions online. Seems that many have had this issue and there are many suggestions but nobody has a fix. Logging the other box did not solve my problem. I am trying to apply SP2 to 3 instances that I have installed on a 2 node cluster. Any help on this would be greatly appreciated.

    Thanks.

  • Stop The Presses!! I found the fix. I found the following article yesterday and requested the patch from Microsoft and downloaded this morning, but it failed when I tried to run it. I then noticed that I simply forgot to read the bottom of the article where it explains replacing the hotfix.exe. I am now going to do the happy dance......

    http://support.microsoft.com/kb/936488

  • Whether the kb-936488 worked for you?

    With Regards
    MeenakshiSundaram Lakshmanan

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic. Login to reply