In SSISDB New folder not able to create.

  • While i'm creating a folder in Integration service catalog - SSISDB i'm getting an error as below,

    TITLE: Microsoft SQL Server Management Studio

    ------------------------------

    Operation 'Create' on object 'CatalogFolder[@Name='dev']' failed during execution. (Microsoft.SqlServer.Management.Sdk.Sfc)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=11.0.3000.0+((SQL11_PCU_Main).121019-1325+)&LinkId=20476

    ------------------------------

    ADDITIONAL INFORMATION:

    An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)

    ------------------------------

    An error occurred in the Microsoft .NET Framework while trying to load assembly id 65536. The server may be running out of resources, or the assembly may not be trusted with PERMISSION_SET = EXTERNAL_ACCESS or UNSAFE. Run the query again, or check documentation to see how to solve the assembly trust issues. For more information about this error:

    System.IO.FileLoadException: Could not load file or assembly 'microsoft.sqlserver.integrationservices.server, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. An error relating to security occurred. (Exception from HRESULT: 0x8013150A)

    System.IO.FileLoadException:

    at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)

    at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)

    at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean forIntrospection)

    at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)

    at System.Reflection.Assembly.Load(String assemblyString)

    Cannot find the folder 'dev' because it does not exist or you do not have sufficient permissions. (Microsoft SQL Server, Error: 10314)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&ProdVer=11.00.5058&EvtSrc=MSSQLServer&EvtID=10314&LinkId=20476

    ------------------------------

    BUTTONS:

    OK

    ------------------------------

    I have tried while Deploying the package in SSIS i'm getting same error.

    why i'm getting this error is there any way to create folder in SSISDB.

  • Hi,

    Are you trying to create this folder "dev" by SSMS, T-SQL or PowerShell ?

    Johan Jezequel
    ** Sorry for my english, I promess you I do my best **

  • Through SSMS only i am trying to create.

  • It seems it could be a collation issue, please check this out :

    https://connect.microsoft.com/SQLServer/feedback/details/620943/ssis-cannot-create-a-folder-under-ssisdb-catalog

    Johan Jezequel
    ** Sorry for my english, I promess you I do my best **

  • Johan_1975 (4/8/2016)


    It seems it could be a collation issue, please check this out :

    https://connect.microsoft.com/SQLServer/feedback/details/620943/ssis-cannot-create-a-folder-under-ssisdb-catalog%5B/quote%5D

    Nice find. Unfortunately it isn't very helpful, since the link is from 2010, reported "bug is fixed", and the work-around is to use native US-English collation. Not a good option for companies who isn't already using that collation.

  • I just had - and solved - the same issue. I found many suggestions which didn't work. This one did the trick for me:

    ALTER AUTHORIZATION ON DATABASE ::[SSISDB] TO sa;

    ALTER DATABASE [SSISDB] SET TRUSTWORTHY ON;

    (Of course: change the database name according to your environment)

    It didn't matter that the database authorization belonged to a sysadmin. It doesn't matter either that sa is disabled on my system (a disabled login can own objects, but do nothing with them!). It had to be set like this, right now.

    Then I was allowed to change the TRUSTWORTHY setting (regardless whether it was already "TRUSTWORTHY ON").

    And then I was allowed to create a new folder. :w00t: Problem solved.

  • I know this thread is old but whoever comes across the same issue , try with Windows Authentication instead and see if that fixes your issue. It did for me

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic. Login to reply