I cannot add a replica because of difference between instances

  • Hi There,

    Let me start with to say I am not a SQL administrator, but I would like to understand.

    I was busy with creating a sql cluster, so far so good. I created a database, created a backup, enabled Always on on every instance and whilst creating the availability group with the wizard I cannot add a replica, because it says there are differences between the instances. At fist I noticed that one of the host had been patched by SCCM and the other was missing some, so I made sure both of them had the same patches. They even show the same version number in SQL studio. I have tried several things for hours, but still no luck. I was hoping that maybe one of you SQL guru's could lead me the way to solving this other then to reinstall everything with all new hosts and all.

    Please see attachment

     

     

    • This topic was modified 4 weeks ago by  vavoem.
    Attachments:
    You must be logged in to view attached files.
  • Edition is different, so standard vs enterprise.

    please post the output of SELECT @@VERSION, so that can be ruled out.

  • I executed SELECT @@VERSION and then I saw a difference indeed. One was standard, the other ones we're Enterprise.

    It is unclear to me , how this could have happened, because all nodes we're installed with the same ansible script. Probably someone responsible for Ansible within our company, has changed something along the way! Thanks for showing me btw!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply