How to resolve RequireKerberos value problem in sql 2008 failover cluster installation process?

  • v-yasu

    SSC-Addicted

    Points: 455

    I set up 2008 sql failover cluster, at last the error message shows 'RequireKerberos is 1' value set to unexpected range...

    I see no Kerbero configuration during the wizard, yet

  • hi_abhay78

    SSCertifiable

    Points: 6205

    we use Kerberos for better security .otherwise the default is NTLM .Not sure where the issue is .

    Can you share the complete error message please ..that will be helpful .

    If you get the error on the setup page , there will be a page icon .Click on that and paste the information on the notepad or direscly here ..

    Awaiting your reply .

    Abhay Chaudhary
    Sr.DBA (MCITP/MCTS :SQL Server 2005/2008 ,OCP 9i)

  • v-yasu

    SSC-Addicted

    Points: 455

    TITLE: Microsoft SQL Server 2008 Setup

    ------------------------------

    The following error has occurred: There was an error setting private property 'RequireKerberos' to value '1' for resource 'SQL Network Name (33SQLCluster)'. Error: Value does not fall within the expected range.

    For help, click: http://go.microsoft.com/fwlink?LinkID=20476&ProdName=Microsoft+SQL+Server&EvtSrc=setup.rll&EvtID=50000&ProdVer=10.0.1600.22&EvtType=0xDCFFB30D%25400X1251FB33

    -------------------------------

    BUTTONS:

    OK

    -------------------------------

    I have looked at the linked resource but still no idea how to resolve such problem..

  • hi_abhay78

    SSCertifiable

    Points: 6205

    I have not seen your enviornment but i can certainly guide here .

    RequireKerberos is the Dword registry value that ensures whether you are using kerberos authentication or not for a Network Name resource.if its 1 its enabled else its 0 [default].

    So what i feel is ,In case you are using kerberos authentication check the resources that its checked in the check box (go to properties of the Network Name resource.)

    Else you can go to the registry and change this value to 1 or 0 as per your enviornment need and if the setup gives you the option to retry , do it .Else run the setup again .If you do not have the permissions to change the registry keys let someone with that permission do that .

    you can find this key under registry HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.x\Cluster()

    hope this helps

    Abhay Chaudhary
    Sr.DBA (MCITP/MCTS :SQL Server 2005/2008 ,OCP 9i)

  • kobayashi.yoshi

    SSC Veteran

    Points: 273

    Hi

    I had also same problem.

    http://social.msdn.microsoft.com/Forums/en-US/sqlsetupandupgrade/thread/6ccf9380-852d-4b59-b128-97e0e870452c

    So far still I couldn't find the solution.

    I'll try to check the registry if I could solve this issue.

  • kobayashi.yoshi

    SSC Veteran

    Points: 273

    Hi

    I checked my registry.

    Since the installation hadn'T complete due to this error,

    no entry can be found in the registry.

    I guess the problem may relate to Active Directry.

  • v-yasu

    SSC-Addicted

    Points: 455

    Hi,

    we can resolve this problem by using SQL slipstream, seems it was a bug with SQL 2008, slipstream integrate sp1 with the setup

    media, and you can install the failover successfully without RequireKerberos problem:)

    Link:

    http://blogs.msdn.com/petersad/archive/2009/03/02/sql-server-2008-basic-slipstream-steps.aspx

    NOTICE:

    [Need to search in C:\SP1 to find sqlsupp* and install the support file for slipstream of SQL 2008!!

    Then SETUP.EXE /PCUSource=C:\SP1 will take effect ?]

  • kobayashi.yoshi

    SSC Veteran

    Points: 273

    Thanks yasu

    It is solved now!

    I have almost spend 3 days for this issue.

    I tried more than 10 times just for intallation....

  • S. Kusen

    SSChampion

    Points: 10874

    One other issue that I had related to this was that the SQL Server Network name set up with Kerberos enabled wouldn't start after the install completed. If you want to use Kerberos, your AD admin will need to create a computer object within AD under your SQL virtual instance name.

    Took me a day to find that tick that was different than other clusters we had running.

    I then re-produced the issue with my AD admin and decided to remove the Kerberos because we don't typically require it at my company.

    Hope this info helps others in their SQL 2008 quests!

    Regards,

    Steve

  • trilist

    SSC Eights!

    Points: 902

    That worked for me too.

    Thank you for this post.

  • jonese

    Grasshopper

    Points: 13

    Thanks. This was of great assistance to us as well.

    -Eric

    http://www.theoperationsgroup.com

  • frk888

    SSC Enthusiast

    Points: 105

    It is a greate help for my SQL2K8 on Win2K8 failover cluster.

    I wondered can I apply other post SP1 CUs together with this /PCUSource extension?

    Thanks ahead!

  • SQLBalls

    SSCarpal Tunnel

    Points: 4610

    Thanks to all on this Thread, I'm really glad it was here.

    Got a couple wierd things though

    I went to

    http://blogs.msdn.com/b/petersad/archive/2009/03/02/sql-server-2008-basic-slipstream-steps.aspx

    but got the error

    The following error occurred:

    The setting 'PCUSOURCE' specified is not recognized.

    Error result: -2068578301

    Result facility code: 1204

    Result error code: 3

    Please review the summary.txt log for further details

    so I followed the link that Peter had placed to his other blog entry

    http://blogs.msdn.com/b/petersad/archive/2009/06/17/creating-a-merged-slipstreamed-drop-containing-sql-server-2008-rtm-service-pack-1.aspx

    When I built this I still got the Kerberos error because i forgot to run sqlsupport.msi from the SP1 extraction.

    pulled it all out, re installed and this time it installed, however it is show version 10.0.1600 the RTM release!

    I'm going to add the other node to my cluster before running the SP to see if it upgrades this time.....

    Twitter: @SQLBalls
    Blog: http://www.SQLBalls.com

  • SQLBalls

    SSCarpal Tunnel

    Points: 4610

    Just to follow up, I ran SP1 on each node and it upgraded just fine. Not sure what the slipstream issue was but at least i have my cluster up and running!:-D

    Twitter: @SQLBalls
    Blog: http://www.SQLBalls.com

  • boumerlin

    SSCrazy

    Points: 2023

    I realize this is an old thread, but I just wanted to add a couple of things. This is the second cluster where we have run into this same issue. The first one we ended up rebuilding, so here is what we have learned:

    1. You will need to slipstream SP1 into the SQL 2008 install. For those of you, like me, who don't follow the cliff notes well on creating a slipstreamed install, here is a more thorough post on creating one:

    http://blogs.msdn.com/b/petersad/archive/2009/02/25/sql-server-2008-creating-a-merged-slisptream-drop.aspx

    2. If you have a hosed SQL 2008 install on a cluster, you will need to uninstall it first. Some of the directions out there indicate you will need to hack the registry to do this. That is how we ended up rebuilding the first cluster!

    Actually all you need to do is uninstall the cluster. To uninstall a cluster, you remove the passive node(s) first by using the setup disk. Go to Maintenance->Uninstall Cluster Node. Then you will need to reboot. Next go to Add/Remove Programs and uninstall what is left of SQL Server. You may need to do this more than once to get all the litter off. You'll need to reboot again. Follow the same steps on the active node(s).

    With the hosed installation, we also had to go to the cluster "Services and Applications", right click on SQL and delete it. This worked and we were able to successfully install SQL 2008 slipstreamed with SP1 after uninstalling the unsuccessful attempt.

    Here are a couple of links on uninstalling a cluster:

    http://msdn.microsoft.com/en-us/library/ms191545.aspx

    http://msdn.microsoft.com/en-us/library/ms189134.aspx

    Hope that helps!

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic. Login to reply