How to change cluster time out setting.

  • pols

    SSC Eights!

    Points: 861

    Hi,

    We configured 2 node cluster. Every early morning 1 am the secondary node is coming out from fail over cluster membership.
    We had a deep dive on this issue and it seems that while firing the Veeam Backup it will take a Snapshot first, during this time the Server may freeze approx. 30 Seconds, in this time we are getting the failure alerts.
    To overcome this issue we had removed the Primary DB Server from Veaam Backup Job [we are taking the Secondary DB Server Backup, this is the replicated live data from Primary] for couple of days. So now there is no issue with Primary DB Server.

    Yesterday we had moved the Veeam Backup window for Secondary Server to 12:00 AM, then we got the same error on 12:09 AM. It seems that during this 30 Seconds [Veeam Snapshot] **Windows Failover Cluster** is trying to do the usual **Basic resource health check** [interval approx. every 10 Seconds] and the Servers can’t communicate each other this time, so it is throwing the error.
    This issue may resolve by increasing the WFC Heartbeat Health check timeout above 40 Seconds.
    Can some one give how to change the WFC Heartbeat Health check timeout 40 Seconds using power shell commands or gui settings?

    steps to chnage the settings and also anything else i need to take care while doing this change..Please i need to finish this by end of the day.. Pls guide.

  • andreas.kreuzberg

    SSCertifiable

    Points: 6046

    Hi,
    you can change the cluster timeout via powershell. But, I think you may lost your microsoft support, if you change the default settings like timeout or  threshold of failover in time xyz.
    Kind regards,
    Andreas

  • pols

    SSC Eights!

    Points: 861

    i changed the samesubnetthreshold value. 
    $clust = Get-Cluster;$Clust.Samesubnetdelay=1000; $clust.SamesubnetThreshold = 40

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply