Excel drivers for ssis package

  • sqlsniffer

    SSC-Addicted

    Points: 484

    Hi,

    I am trying to connect to excel source but its throwing connection error. After googling it suggested  my system might not have ACE driver installed. I checked it and it is. 

    W hen I try to run the Microsoft Access Database Engine (2012) 64 bit, all it does is to take me to repair mode .

    Please suggest me what options can I try.

    Thanks,
    Bulbul

  • Phil Parkin

    SSC Guru

    Points: 244739

    Comment deleted

    If the answer to your question can be found with a brief Google search, please perform the search yourself, rather than expecting one of the SSC members to do it for you.
    See https://www.sqlservercentral.com/articles/forum-etiquette-how-to-post-datacode-on-a-forum-to-get-the-best-help/ for details of how to post T-SQL code-related questions.

  • Thom A

    SSC Guru

    Points: 98720

    Ahh, the bane in our side that is the "ACE" drivers.

    What version of SSIS are you using? When you're executing the package, how are you doing so, and are you running it in 32 bit compatibility or not?

    Thom~

    Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does.

  • SQL Surfer '66

    SSCertifiable

    Points: 5159

    If you're running into to the connection error in Data Tools (SSDT) you also need to install Access Database Engine 32-bit.
  • sqlsniffer

    SSC-Addicted

    Points: 484

    Hi Phil
    Microsoft SQL Server Integration Services Designer
    Version 14.0.600.250.

  • sqlsniffer

    SSC-Addicted

    Points: 484

    Hi SQL Surfer '66 ,
    Would that mean uninstallation of 64 bit.

    Thanks,
    SQLSniffer

  • sqlsniffer

    SSC-Addicted

    Points: 484

    Phil Parkin - Tuesday, November 14, 2017 10:37 AM

    Comment deleted

    Hi Phil
    Microsoft SQL Server Integration Services Designer
    Version 14.0.600.250.

  • sqlsniffer

    SSC-Addicted

    Points: 484

    SQL Surfer '66 - Wednesday, November 15, 2017 5:46 AM

    If you're running into to the connection error in Data Tools (SSDT) you also need to install Access Database Engine 32-bit.

    Hi,
    I checked out, and I have 32 bit ACE installed and my windows is 64 bit.

    Thanks,
    SQLSniffer

  • Thom A

    SSC Guru

    Points: 98720

    sqlsniffer - Friday, November 17, 2017 2:54 AM

    Phil Parkin - Tuesday, November 14, 2017 10:37 AM

    Comment deleted

    Hi Phil
    Microsoft SQL Server Integration Services Designer
    Version 14.0.600.250.

    That's not SSIS, That's the version of SSDT you have installed (SSDT 2015). I'm not running SQL Server 2017 because I have SSMS 2017 installed (I'm running SQL Server 2012).

    Can I thus assume that you're running this locally, and not on your Server? Also, you can,safely have both the 32 bit and 64 bit ACE drivers installed. You'll also then need to run your package/project in 32 bit mode.

    Thom~

    Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does.

  • Thom A

    SSC Guru

    Points: 98720

    sqlsniffer - Friday, November 17, 2017 2:56 AM

    Hi,
    I checked out, and I have 32 bit ACE installed and my windows is 64 bit.

    Thanks,
    SQLSniffer

    This was posted after i loaded the page. Are you, therefore, running your package/project in 32bit mode if you have the 32 bit ACE drivers installed?

    Thom~

    Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does.

  • SQL Surfer '66

    SSCertifiable

    Points: 5159

    sqlsniffer - Wednesday, November 15, 2017 10:08 AM

    Hi SQL Surfer '66 ,
    Would that mean uninstallation of 64 bit.

    Thanks,
    SQLSniffer

    No, it does not mean uninstallation of 64-bit but 32-bit is also required because your development environment (SSDT) is 32 bit.

  • twin.devil

    SSC-Insane

    Points: 22208

    Just want to share few comments might help the OP

    If you are running in your ssis package in the Designer mode i.e. in SSDT then you need to make sure you have 32 bit ACE driver. Doesn't matter if you are using a 64 bit OS.
    If you want to run your ssis package using DTEXE Utility and your OS is 64 bit, then you have two option whether to run in 32 bit or you want to run it in 64 bit.

    For more detail you can refer to Installing the Microsoft.ACE.OLEDB.12.0 Provider for Both 64-bit and 32-bit Processing

    Hope it helps.

  • sqlsniffer

    SSC-Addicted

    Points: 484

    twin.devil - Friday, November 17, 2017 3:47 AM

    Just want to share few comments might help the OP

    If you are running in your ssis package in the Designer mode i.e. in SSDT then you need to make sure you have 32 bit ACE driver. Doesn't matter if you are using a 64 bit OS.
    If you want to run your ssis package using DTEXE Utility and your OS is 64 bit, then you have two option whether to run in 32 bit or you want to run it in 64 bit.

    For more detail you can refer to Installing the Microsoft.ACE.OLEDB.12.0 Provider for Both 64-bit and 32-bit Processing

    Hope it helps.

    Running on designer environment, checked that I have 32 bit ACE driver installed.(but office is not installed), I am not using the DTEXE utility. Still it throws the same error.

  • Thom A

    SSC Guru

    Points: 98720

    sqlsniffer - Friday, November 17, 2017 4:26 AM

    twin.devil - Friday, November 17, 2017 3:47 AM

    Just want to share few comments might help the OP

    If you are running in your ssis package in the Designer mode i.e. in SSDT then you need to make sure you have 32 bit ACE driver. Doesn't matter if you are using a 64 bit OS.
    If you want to run your ssis package using DTEXE Utility and your OS is 64 bit, then you have two option whether to run in 32 bit or you want to run it in 64 bit.

    For more detail you can refer to Installing the Microsoft.ACE.OLEDB.12.0 Provider for Both 64-bit and 32-bit Processing

    Hope it helps.

    Running on designer environment, checked that I have 32 bit ACE driver installed.(but office is not installed), I am not using the DTEXE utility. Still it throws the same error.

    But are you running the package in 32bit mode...? If you only have the 32 drivers install, and just using DTExec then  you'll likely trying to run it as a 64 bit package.

    Thom~

    Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does.

  • sqlsniffer

    SSC-Addicted

    Points: 484

    Thom A - Friday, November 17, 2017 4:33 AM

    sqlsniffer - Friday, November 17, 2017 4:26 AM

    twin.devil - Friday, November 17, 2017 3:47 AM

    Just want to share few comments might help the OP

    If you are running in your ssis package in the Designer mode i.e. in SSDT then you need to make sure you have 32 bit ACE driver. Doesn't matter if you are using a 64 bit OS.
    If you want to run your ssis package using DTEXE Utility and your OS is 64 bit, then you have two option whether to run in 32 bit or you want to run it in 64 bit.

    For more detail you can refer to Installing the Microsoft.ACE.OLEDB.12.0 Provider for Both 64-bit and 32-bit Processing

    Hope it helps.

    Running on designer environment, checked that I have 32 bit ACE driver installed.(but office is not installed), I am not using the DTEXE utility. Still it throws the same error.

    But are you running the package in 32bit mode...? If you only have the 32 drivers install, and just using DTExec then  you'll likely trying to run it as a 64 bit package.

    I have set my Run64BitRuntime to False

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic. Login to reply