Error while Assigning database level role (db_datareader) to SQL login (Domain Account)

  • chetanr.jain

    Hall of Fame

    Points: 3938

    Team,

    I got an error while creating a User for Domain Account. Below is the screen shot of the error (error : 15401)

    Database instance is on SQL 2003 SP3. ( I know it is out of support, But the customer is relutanct to upgrade)

    On Google search, i found below article which is best matching for this error

    http://support.microsoft.com/kb/324321

    I have follows each step of troubleshooting. But still the issue persists.

    Step 1. The login does not exist == The login is very much exist in the domain as i am able to add the same domain id to other database instances

    Step 2. Duplicate security identifiers == i have used this query to find duplicate SID

    /* SELECT name FROM syslogins WHERE sid = SUSER_SID ('YourDomain\YourLogin') */

    But there was only one row returned with create date of today's.

    Error while Assigning database level role (db_datareader) to SQL login (Domain Account)

    Step 3. Authentication failure == Domain is available. User is able to login on other servers via RDP connection.

    Step 4. Case sensitivity == Database collation is set to Case insensitivity. (CI)

    Other two 5. Local Accounts & 6. Name resolution == is not applicable to me.

    I tried other ways also.

    A. Creating login and providing permission in one go only = User account is not created

    B. Instead of GUI, use query to create login and provide required permission = Same error.

    Does anybody has faced any such situation.

  • Lowell

    SSC Guru

    Points: 323331

    didn't see the screenshot you attatched, and you said "SQL 2003 SP3", did you mean 2000, since that is the forum you posted? 2005?2008?

    Lowell


    --help us help you! If you post a question, make sure you include a CREATE TABLE... statement and INSERT INTO... statement into that table to give the volunteers here representative data. with your description of the problem, we can provide a tested, verifiable solution to your question! asking the question the right way gets you a tested answer the fastest way possible!

  • chetanr.jain

    Hall of Fame

    Points: 3938

    oops. my mistake.. it is SQL 2000 SP3

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply