Error - SSIS Error Code DTS_E_OLEDBERROR. An OLE DB error has occurred. Error code: 0x80040E4D

  • sql crazy kid

    Ten Centuries

    Points: 1388

    Hi ,

    I have a problem with SQL server Job . Job keep failing while executing package . Job and Package on Same server.

    If you run package from MANAGEMENT STUDIO from the same server , its works fine.

    "DestinationDB" Description: SSIS Error Code DTS_E_OLEDBERROR. An OLE DB error has occurred. Error code: 0x80040E4D. An OLE DB record is available.

    Source: "Microsoft SQL Server Native Client 10.0" Hresult: 0x80040E4D

    Description: "Login failed for user 'DOMAIN\SERVER$'.". End Error Error: 2015-05-26 11:27:37.65 Code: 0xC00291EC

    Source: EST_NameOfTASK Execute SQL Task

    Description: Failed to acquire connection "DBnameDestination".

    Connection may not be configured correctly or you may not have the right permissions on this connection. End Error

    DTExec: The package execution returned DTSER_FAILURE (1). Started: 11:27:36 Finished: 11:27:37 Elapsed: 1.328 seconds. The package execution failed. The step failed.

  • michal.lisinski

    SSCertifiable

    Points: 6873

    HI

    You have to save the password in configuration file.

    Regards

    Mike

  • sql crazy kid

    Ten Centuries

    Points: 1388

    Thanks you ..

    I got the issue now . In the configuration file , connection string was defined for Windows authentication . Since I am logged in and running through the management studio its works . But on SQL job its doesn't use windows authentication hence failed . As solution i have configured my connection string with SQL Authentication and worked well.:-P

  • Crazybabu

    SSC Journeyman

    Points: 97

    Hi,

    is there any other way to achieve this without configuration

  • Lowell

    SSC Guru

    Points: 323349

    yes. you can create a credential with windows credentials, and then a proxy in SQL agent.

    with that in place, you can modify the job step that calls the SSIS package to use that credential instead of the default.

    here's a decent article on how to set it up:

    https://www.simple-talk.com/sql/database-administration/setting-up-your-sql-server-agent-correctly/

    Lowell


    --help us help you! If you post a question, make sure you include a CREATE TABLE... statement and INSERT INTO... statement into that table to give the volunteers here representative data. with your description of the problem, we can provide a tested, verifiable solution to your question! asking the question the right way gets you a tested answer the fastest way possible!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic. Login to reply