Error saving report to PDF

  • tgonzalez

    SSC Enthusiast

    Points: 182

    Hi, I was wondering if someone out there could help me. We just upgraded to 2008. All our reports and subscriptions are working great with the exception of the subscriptions that try to save reports with no results to PDF. These fail with: An error occurred during rendering of the report. If the reports have results they save correctly. I need these blank reports though.

    Here is a bit of the error log:

    INFO: RenderForNewSession('/NextGen/Transportation/External Routes/NGTR_EarlyExternalWeekendRoutes')

    runningjobs!WindowsService_7!3bc!09/28/2009-06:01:01:: i INFO: Adding: 2 running jobs to the database

    reportrendering!WindowsService_7!ddc!09/28/2009-06:04:09:: e ERROR: Throwing Microsoft.ReportingServices.ReportProcessing.UnhandledReportRenderingException: An error occurred during rendering of the report., ;

    Info: Microsoft.ReportingServices.ReportProcessing.UnhandledReportRenderingException: An error occurred during rendering of the report. ---> Microsoft.ReportingServices.OnDemandReportRendering.ReportRenderingException: An error occurred during rendering of the report. ---> System.NullReferenceException: Object reference not set to an instance of an object.

    at Microsoft.ReportingServices.Rendering.ImageRenderer.Renderer.ProcessPage(RPLReport rplReport, Int32 pageNumber, FontCache sharedFontCache, List`1 paragraphsItemizedData)

    at Microsoft.ReportingServices.Rendering.ImageRenderer.PDFRenderer.Render(Report report, NameValueCollection deviceInfo, Hashtable renderProperties, CreateAndRegisterStream createAndRegisterStream)

    at Microsoft.ReportingServices.Rendering.ImageRenderer.RendererBase.Render(Report report, NameValueCollection reportServerParameters, NameValueCollection deviceInfo, NameValueCollection clientCapabilities, Hashtable& renderProperties, CreateAndRegisterStream createAndRegisterStream)

    --- End of inner exception stack trace ---

  • Neuro

    Ten Centuries

    Points: 1063

    just a thought , but try editing the report and putting a text box that will always render ,

    like a dot or something , make it almost white too , that might sort your problem out

    another thought comes to mind about consuming White space,

    check your report property and have a play with it 🙂

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic. Login to reply