Error in pulling data from SQL Server using RDA

  • Saifullah-390699

    SSC Rookie

    Points: 49

    I have an application running at "Pocket PC 2003 SE Emulator", I am using Mobile SQL Server

    running at my development computer where i have IIS running while i have SQL server 2005

    running at an other Server at the network. I have configured and created the virtual

    directory according to the steps available in the MSDN. Now i have sqlcesa30.dll in my

    virtual directory and i can access it using  http://localhost/TestMobileSQL/sqlcesa30.dll.

    I tried to create an RDA object and when i call its pull method using the above mentioned

    URL, it generates an error "An error has occurred on the computer running IIS. Try

    restarting the IIS server.";

    Then i changed the URL to http://192.168.0.5:81/TestMobileSQL/sqlcesa30.dll the error

    generated is like "The HTTP request failed due to incorrect format or content. Try

    restarting the IIS server."

    What am i missing?

    Please let me know what to do with it?

    Whether we can use SQL Mobile at emulator or not?

  • Jeff Gray

    SSChampion

    Points: 10637

    What happens if you navigate to the first URL?  The second?  They are not the same.  The first one specifies port 80 (http default port) and the second one specifies port 81.  Also, the IP address is most likely not the same.  localhost <> 192.168.0.5 under normal circumstances....

    That would explain why you get different results with the two.

    Anyway, try it with IE and let me know what you get back.  Also you should check the IIS Log file on the IIS machine.

    jg

  • Saifullah-390699

    SSC Rookie

    Points: 49

    I have tried both of above URL having the same result from IE.

    I put computer name instead of IP in the string then it works.

    I have another problem. I have DB at Emulator, With a table and few rcords in table. I uses "Select * from Tablename " but it produces an error "Unable to parse the query Error # 25501.". I uses this query from the query analyzer of the SQL Mobile at Emulator it also produces same error. I could not understand why it is giving error, I opened the table from SQL Mobile at Emulator it shows records.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply