Error 17058 when trying to start MSSQLSERVER service

  • luissantos

    SSCertifiable

    Points: 7346

    Hello comunity

    After running the setup of sql server 2008 on my HP server with OS Windows server 2008 R2 standard 64 bits,

    the setup return errors failed on theses services:

    -Database engine services

    -Sql Server Replication

    -Full text search

    -Reporting Services

    When i try to start MSSQLSERVER, i receive the following error :

    event ID 17058

    initerrlog: Could not open error log file ''. Operating system error = 3(failed to retrieve text for this error. Reason: 15105).

    Curiously, the installation on : C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQL\

    have only create theses folders : binn, install and upgrade

    and also these files:

    -sql_engine_core_inst_keyfile.dll

    -sql_fulltext_keyfile.dll

    Could someone give me some help , because is the first time that i have this problem and i don´t know how to solve them.

    Many thanks and best regards

    Luis Santos

  • luissantos

    SSCertifiable

    Points: 7346

    Hello comunity

    I solve this problem and for those person that have the same one would should install sql server 2008 not by the autorun option, but you must with right click select : Open and Run setup as administrator.

    Also, if you open SSMS and you try to browse server name and nothing appears, you need just to write

    the correct server name or instance\servername.

    I hope this conclusion help other users with this kind of situation.

    Best regards.

    Luis Santos:w00t:

  • julian.hatwell

    SSC Veteran

    Points: 257

    Hello folks - I have a similar problem with my box. This was working fine before the weekend.

    The server is a VM, sharing a drive with a number of other VM's. We had a major windows update pack applied on Saturday. 100's of patches that had not been applied for a few months. This filled up the physical disc where the servers were running and they all shut down unexpectedly.

    We freed up some disc space and restarted the OS, but SQL server services did not start up. Trying to restart them manually gives me this message in the even log:

    A file activation error occurred. The physical file name 'E:\MSSQL\MSSQL10_50.MSSQLSERVER\MSSQL\Binn\mssqlsystemresource.ldf' may be incorrect. Diagnose and correct additional errors, and retry the operation.

    Trying to start SQL server from cmd: sqlservr -T3608 gives the following message multiple times:

    Error: 17058, Severty: 16, State: 1.

    initerrlog Could not open error log file ''.

    Operating system error = 3(failed to retrieve text for this error. Reason 15105).

    I have checked and the file exists at: 'E:\MSSQL\MSSQL10_50.MSSQLSERVER\MSSQL\Binn\mssqlsystemresource.ldf' so not sure what I can do about that.

    Can anyone help?

  • julian.hatwell

    SSC Veteran

    Points: 257

    If anyone should follow this up - I found a clue in my trusty Wrox Press SQL Server Admin book "The resource database is only written to during installation or applying a service pack."

    Given my issue happened right after a service pack was applied and we had an unexpected shutdown, I thought the best thing was to re-apply the service pack. This fixed the problem.

  • jpipia

    SSC Enthusiast

    Points: 172

    I am getting the exact same error. It seems out of the blue though since I didn't apply any service packs. The only thing I can think of that changed was a bunch of Windows updates a while ago.

    The .ldf file is there. Anyone know how I can get it fixed?

    Thanks

    Judy McNeil

  • Bipsy

    SSCrazy

    Points: 2207

    Your installation is not fully completed.

    try repairing your installation or remove all sql components , reboot your machine and try to install it again.

  • jpipia

    SSC Enthusiast

    Points: 172

    Thanks. I will try to repair with the CD. The thing is, the installation has been completed and working for over a year.

    It is just a development instalation and no one is counting on it at the moment. I just get nervous when things seem to break for no reason. I like to know the reason.

  • michael_gm

    SSC Enthusiast

    Points: 106

    this is a permission problem!... you must try access the log with the user is running sql server.... orrrr.....only for testing... try adding the user is running sqlserver as admin and you'll notice that you may start the service....

    Michael Guerra.

  • mxhxr

    SSC-Addicted

    Points: 471

    It's a permissions problem.

    To verify that's the case in your scenario, give the user that you are running the SQL Server service under administrative rights on the SQL Server machine. Then try to start the service. If it succeeds, you can then start to chip away at the rights to an acceptable point. But try this prior to reinstalling SQL Server or any of the other drastic measures mentioned prior.

  • j.noruzi

    SSC Enthusiast

    Points: 115

    Hello guys.

    I had the same problem.

    my problem occurred when i change start-up parameters for sql server 2008r2 service. i had a mistake when changed that parameters.

    Mistake => i forgotten putting ";" (semicolon) between each parameter. i corrected this mistake so problem solved.

    this is Correct Start-up Parameters :

    -dC:\Program Files\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\MSSQL\DATA\master.mdf;-eC:\Program Files\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\MSSQL\Log\ERRORLOG;-lC:\Program Files\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\MSSQL\DATA\mastlog.ldf

  • er_thomas21

    SSC Rookie

    Points: 39

    Dear All

    As per the scenario above I also faced the same problem with one of my SQL server 2008 R2 edition. After troubleshooting and cross checking with another instance I found that there are two group accounts which need permission on the ERRORLOG file. i.e

    1. SQLServerMSSQLUser$machinename$MSSQLSERVER

    2. SQLServerSQLAgentUser$machinename$MSSQLSERVER

    if there is some problem the account dont have appropriate permission on the file than you will face the SQL server Error 17058.

    So to resolve this issue

    MSSQLUSER should have full permission

    SQLAgentUser should have read,write,read and execute permission on the file

    Best of luck

    Thomas(The SQL DBA)

  • edgar.barrios

    SSC Journeyman

    Points: 75

    I got the same error several times. I decided to run the setup and a repair on my instance to see if that would help the issue. It didn't. After several tries and changed to my services and log in credentials i went to the "source". Went and looked at my installation folder and found that for some reason one of my folders was missing permissions. I added my local admin local service and network service to it with full rights tried to run the service one more time and that fixed the issue.

    It was a simple permissions issue. Hope this helps guys.

    ps.- I notices updates where done a couple of nights before so im thinking that had something to do with the change on permissions.

    ps2.- My Database and install files are on my VM Data Bank. hope this helps.

  • This was removed by the editor as SPAM

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic. Login to reply