Encryption Key Issue

  • Kwisatz78

    SSChampion

    Points: 12478

    Hi all

    I recently had a problem where someone changed the Reporting Services account in services which resulted in an symmetric key problem. We don't have a backup of the key.

    I have deleted the key in order to create a new one with the expectation that I can re-input the datasource details. However I have an issue with the subscription. When I enter the report and click subscription I get the error:

    The report server is unable to access encrypted data. Apply a back-up key or delete all encrypted content. (rsEncryptedDataUnavailable) (rsRPCError) Get Online Help

    But I have already deleted the key and created a new one. Can anyone advise on what I can do to access this subscription. I have also tried the comman line rskeymgmt -d but have the same problem.

    Thanks

  • Kwisatz78

    SSChampion

    Points: 12478

    In the end I had to delete the subscription from the ReportServer database.

  • david.robson

    SSC Veteran

    Points: 265

    Can you add more info? I've got the same problem. My emailed subscriptions are fine, the ones that save to a folder on the SAN all generate the same error. What is it that I need to delete, and out of which tables?

    Thanks!

  • Thom A

    SSC Guru

    Points: 98326

    david.robson (8/18/2016)


    Can you add more info? I've got the same problem. My emailed subscriptions are fine, the ones that save to a folder on the SAN all generate the same error. What is it that I need to delete, and out of which tables?

    Thanks!

    Replying to a 7 year old topic probably isn't going to get you far. I'd suggest making a new one, outlining exactly what the problem you're having is and someone here will be able to help more concisely to your specific problem 🙂

    Thom~

    Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic. Login to reply