Empty Resultset from Linked Server

  • I created a link to my Oracle server on SQL Server 7.0. When I run a query in QA against the linked server, the only thing returned are the column headings and no data. I even tried creating a view, but I got the same results ... an empty resultset. I cannot find an article any where stating a possible cause. Does anyone have an idea why this is happening?


  • Can you post the select statement?

  • The linked server is named 'Warehouse'. Here is the select statement that should return the data in our 'Products' table. I don't get a thing but headers:

    select * from openquery(Warehouse, 'select * from Products')

  • Do you query other tables with nothing too?

    Try select * from openquery(Warehouse, 'select * from SYS.ALL_USERS'). It should give all your username in Oracle database.

    How to you configure Oracle Linked server, using Microsoft ODBC for ORACLE or something else?

  • I used Microsoft ODBC for Oracle. I believe that I referenced a DSN on the SQL Server. As for running the query on the SYS.ALL_USERS, I don't have permission to do that. When I expand the linked server in EM, I can see all of the tables just fine.

  • I would check whether user who is configured in Oracle Linked server 'Warehouse' in SQL Server has select permission to 'Products' table in Oracle side.

  • I verified the user account. It does work when I request data through MS Access to the Oracle table.

  • I am facing similar issue. If it got resolved for you could you help me

Viewing 8 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic. Login to reply