DTS Package not running

  • I have a DTS package in SQL 2000 that uses an Execute process task. Basically, I have a compiled VB app that cleans up data files before they go are loaded into the SQL tables. The job runs fine in the DTS window, but when you schedule it, it seems to get hung up on the Execute process task step. Any clues?

  • One thing I've noticed with the Execute Process task is that if your process has any type of User interface it will hang. I have a similar application as yours, and it would always hang even though it worked via command-line inputs by itself, or if I ran that step in the DTS designer. I had to recompile the app to run from the sub Main which called the rest of the code, and it worked fine.

    If you check the task manager when your scheduled task runs, you should see that the process has been started, but the CPU usage is 00. Once I implemented the fix above, everything worked well.

    I hope this helps. Let me know!


Viewing 2 posts - 1 through 1 (of 1 total)

You must be logged in to reply to this topic. Login to reply