display cluster alwayson in windows

  • abdalah.mehdoini

    SSC Eights!

    Points: 899

    hello ,

    I need your help please

    in my server SQL on  ssms I can display my avaibility group always on and the nodes and the listen so if I connect through failover cluster manager I have nothing

    Sans titre

    Sans titre

    thanks

     

     

  • Jeffrey Williams

    SSC Guru

    Points: 88696

    Right-click on 'Failover Cluster Manager' in the left-pane and connect to one of the nodes in the cluster.  If you are remoted into the server - connect to that node, if you are running from your workstation you can connect to any node or the cluster name.

    Jeffrey Williams
    Problems are opportunities brilliantly disguised as insurmountable obstacles.

    How to post questions to get better answers faster
    Managing Transaction Logs

  • abdalah.mehdoini

    SSC Eights!

    Points: 899

    I have This error message

    Sans titre

     

    Attachments:
    You must be logged in to view attached files.
  • Jeffrey Williams

    SSC Guru

    Points: 88696

    Seem pretty clear - you need administrator access to the servers in the cluster to be able to use cluster manager.

    Jeffrey Williams
    Problems are opportunities brilliantly disguised as insurmountable obstacles.

    How to post questions to get better answers faster
    Managing Transaction Logs

  • Wecks

    Say Hey Kid

    Points: 701

    I believe the  reason for this is that when you created the availability group in ssms you had to specify the cluster type.

    The options were

    NONE

    ETERNAL

     

     

    There is another option but it would not of shown up and this is Windows Failover Cluster yet it is not listed.

    Unless this option is selected you will not be able to manage The AG role via the cluster manager.

    For some reason if your remove the Availability Group and recreate the Windows Failover Cluster is listed.  I would recommend once you have remove the group please disable the Always On Availability Group feature in the Configuration manager and then re-enable to this seems to give it a kick.

     

    To check if this is defiantly the reason select the properties of the Availability Group in SSMSand check the cluster type.  If NONE or EXTERNAL are selected then this confirms it.

     

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic. Login to reply