Disk space

  • Admingod

    SSCertifiable

    Points: 5891

    I noticed the system volume information is consuming the disk space on database server log drive. Also found that shadow copy is disabled but maximum size is not configured to use limit. My understanding is that during the setup of server someone would have not configured properly to use limit. Do you agree with me? How do i get the space back? Just using the limit should fix it?

  • Mr. Brian Gale

    SSC-Insane

    Points: 23067

    My guess is you have system restore turned on for that drive.

    Setting a limit for VSS likely won't make a difference, but reducing the limit for system restore or turning off system restore on that drive will probably help.

    Link - https://appuals.com/fix-system-volume-information-folder-is-large/

    If that is not the case, might want to talk to your SAN team and/or the server admin team as they may have something on the SAN that puts something in that folder (unlikely) or a GPO (again unlikely) or something.

    It is highly unlikely that having a feature turned OFF and configured for no limit will cause Windows to throw data into that folder.  Having VSS max size not configured is a perfectly acceptable configuration, especially if VSS is off and it will not cause any issues with disk space.  They only way it COULD would be if you had VSS ON for a while to build up a lot of data then you turned it off and even then, I would expect windows to clean that up.  Protection (aka system restore) will keep the files on disk but it has a disk cleanup button on the configuration screen.

  • TL

    Old Hand

    Points: 345

    Another thing to check is to see if any other drives on the box are using volume shadow copy and storing them on your log drive.  I've seen systems set up where all the drives pointed their copies at a singe drive.

    Setting a limit should get the space back, but won't let you know why it was consumed in the first place.

     

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply