disable remote access

  • Daxesh Patel

    Hall of Fame

    Points: 3208

    I am trying to disable remote access for a SQL instance

    Here is what I did in SSMS,

    Right click server instance-> click properties -> connections (server properties)-> unchecked "Allow remote connections to this server"

    Then I restarted sql service

    But still I am able to connect from my local machine

    Do I miss something?

  • Daxesh Patel

    Hall of Fame

    Points: 3208

    Ok, instead of "restart" I "stopped" and then "started" sql service

    and now I am not able to connect from my local machine.

    Not sure about diffrence between "restart" and "Stop + Start"

  • Orlando Colamatteo

    SSC Guru

    Points: 182270

    Daxesh Patel (7/17/2012)


    Ok, instead of "restart" I "stopped" and then "started" sql service

    and now I am not able to connect from my local machine.

    Not sure about diffrence between "restart" and "Stop + Start"

    There should be no difference. The "Restart" button in the SQL Configuration Manager and Services MMC is just a GUI feature that does a "Stop" service operation immediately followed by a "Start" service operation.

    __________________________________________________________________________________________________
    There are no special teachers of virtue, because virtue is taught by the whole community. --Plato

  • tomgough

    Old Hand

    Points: 382

    I've seen the same myself - after the restart I checked the "running values" for the config as well and that showed "Allow Remote Connections" as unchecked. I still have no idea what happened

  • dbafromthecold@gmail.com

    SSChampion

    Points: 10090

    Disable TCP/IP in SQL Server configuration manager?

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic. Login to reply