DB@ Linked Server - Cannot initialize the data source object of OLE DB provider "IBMDASQL"

  • ChrisMoix-87856

    SSCertifiable

    Points: 7288

    I'm trying to set up an OLE DB based Linked Server on a SQL Server 2005 machine (SQL Server 2005 64-bit running on Windows Server 2003 64-bit). to access DB@ on an AS400 via the IBM Client Access drivers (V5R4). I can't get the Linked Server to work, and I can't find any good information on the error anywhere online.

    I can get an ODBC based Linked Server to work, but I get the following error with the Managed (.Net) providers:

    Cannot initialize the data source object of OLE DB provider "IBMDASQL" for linked server "DB2400"

    As you can see form the error, I am trying to get the IBMDASQL data provider to connect, but I keep getting the error.

    Does anyone know how to get this to work?

  • SQL ORACLE

    One Orange Chip

    Points: 27807

    Did you have a chance to read the article below?

    http://www.mcpressonline.com/database/db2/db2-integration-with-sql-server-2005-part-i-linked-server-enhancements.html

    May it help.

  • ChrisMoix-87856

    SSCertifiable

    Points: 7288

    Yep, I read that article, and a lot of the comments on the site by people having the same problem as me.

    it seems like Microsoft didn;t think through the Linked Servers and 64-bit stuff when they rolled out SQL Server 2005, from all of the problems that I've read about.

  • Jack Corbett

    SSC Guru

    Points: 184380

    Sounds like there is not a 64 bit IBMDASQL driver. I know that I had problems with SQL 2000 and IBMDASQL linked servers and preferred using the ODBC driver as it worke dmore consistently.

    Jack Corbett
    Consultant - Straight Path Solutions
    Check out these links on how to get faster and more accurate answers:
    Forum Etiquette: How to post data/code on a forum to get the best help
    Need an Answer? Actually, No ... You Need a Question

  • macbolan75

    SSC Rookie

    Points: 31

    Not that this is your specific issue but after hours and hours of reading and reading and reading I found a lot of these issues come from a setting with the provider itself.

    On sql server in server objects drill down to your specific provider and right click on it and select 'properties'. In your case the provider name is 'IMBDASQL'.

    Once the properties are open make sure you check the box next to "Allow Inprocess" then select ok. Should work now

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic. Login to reply