configure SSL for SSRS - The request failed with HTTP status 401: Unauthorized.

  • Hi,

    We have SQL Server 2005 Reporting Services installed on Server A, which is in DMZ and its databases ReportServer & ReportServerTempDB are in a Server B,

    which is in our internal network. Both the Servers are NOT in domain & they just belong to Workgroup. The web application Server

    which points to Report Server is Internet facing.

    We have a wild card certificate and it’ name is *.abc.com.

    While configuring SSL from Reporting Services Configuration Manager tool, we have given the certificate name as servername.abc.com

    In RSReportServer.config File, the url given as <UrlRoot>https://servername.abc.com/reportserver</UrlRoot&gt;

    In RSWebApplication.config, the url given as

    <ReportServerUrl>https://servername.abc.com/ReportServerProd</ReportServerUrl&gt;

    Within the Reportserver Server A, when I open the ReportServer url https://servername.abc.com/reportserver in internert explorer, a pop-up is coming asking for

    credentials and after providing credentilas, it’s gives me the error You are not authorized to view this page. (same for Report manager)

    From outside the ReportServer Server A, I'm able to get into https://servername.abc.com/reportserver.

    From outside the ReportServer Server A, when I browse report manager url https://servername.abc.com/reports, I'm getting the below error:

    The request failed with HTTP status 401: Unauthorized.

    So for the above scenario, can I apply the below fix given in the link? http://clarktechie.wordpress.com/2007/05/09/report-server-error-using-ssl/

    Follow these steps:

    1. Click Start, click Run, type regedit, and then click OK.

    2. In Registry Editor, locate and then click the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    3. Right-click Lsa, point to New, and then click DWORD Value.

    4. Type DisableLoopbackCheck, and then press ENTER.

    5. Right-click DisableLoopbackCheck, and then click Modify.

    6. In the Value data box, type 1, and then click OK.

    7. Quit Registry Editor, and then restart your computer or just restart IIS

    Reference: http://support.microsoft.com/default.aspx?scid=kb;en-us;896861

Viewing post 1 (of 1 total)

You must be logged in to reply to this topic. Login to reply