Can't see SSAS 2008 Cube in Excel

  • I've deployed my cube on a production server using BIDS 2008 and it works perfectly fine at the server level. However, when I try to access the cube using Excel, I'm not able to see the cube. I don't have any roles created on my cube and I have the full read and write access to the server. Can any one please help me?


  • U need to connect to the Cube datasource. To conenct the datasource go to the data tab and click on connections from u can select ur cube datasource and then u r good to go.

  • You also may need to click on the Test Cube Security link in the role to which you are assigned. This is not intuitive at all, but it seems to be necessary.

  • Didn't see a final solution here, was this resolved? I'm having the same issue. All permissions appear to be set correctly, but I can't see the cube itself when trying to setup the connection in Excel. Strangely enough, I copied an existing connection file for a different cube and modified it to point to the new cube, and voila, works like a charm. Not looking to have all the users do this, but it does point to the read permissions being setup correctly.

  • Hi,

    I had 3/6 cubes that were on the server and were not showing up in Excel. On further investigation, those 3 cubes had no "facts" associated with them. (I verified by browsing the cubes from within SSAS.) I'm surmising that Excel will display only those cubes with data in them.

    In my situation, the cubes were part of a vendor supplied solution. My client did not "purchase" these three cubes, so it is possible that they contained some sort of "flag" that prevented them from showing up in the list. This probably doesn't apply to you, but it's something to keep in mind.



  • Each cube has a visible property. Maybe it was somehow set to false? I know this is an old thread, but this just happened to me, and that was the solution.

  • Thank you for the visibility notice. This was my problem also.

  • thank you. It was very good tip with Visible properties.

    When I migrated the ssas Project from SQL 2008r2 to sql2012r2 this properties was reseted automatically to false.

Viewing 8 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic. Login to reply