Can't reach site to install MS Reporting Services Tools

  • Hello experts,

    I found what seems like the perfect set of tools that I need to migrate reports from one SSRS instance to another. The info I used is here:

    https://www.mssqltips.com/sqlservertip/4738/powershell-commands-for-sql-server-reporting-services/

    The first step is to install the tools using this command in PowerShell:

    Install-Module -Name ReportingServicesTools

    However, I get this message when I try the command:

    PS C:\WINDOWS\system32> Install-Module -Name ReportingServicesTools
    WARNING: Unable to download from URI 'https://go.microsoft.com/fwlink/?LinkID=627338&clcid=0x409' to ''.
    WARNING: Unable to download the list of available providers. Check your internet connection.

    Below I have posted screenshots of additional messages/errors.

    Does anyone know how I can install this module when encountering these errors? At first I assumed it was because internet was blocked for security reasons on one server that I tried. But I just checked another server and it can reach Google, etc. So I don't know what's interfering with the installation.

    Alternatively, is there a way to install these tools from some kind of offline installation package?

    Here is some additional info in case this is a version issue:

    PS C:\WINDOWS\system32> Get-PackageProvider -ListAvailable

    Name Version DynamicOptions
    ---- ------- --------------
    msi 3.0.0.0 AdditionalArguments
    msu 3.0.0.0
    PowerShellGet 1.0.0.1 PackageManagementProvider, Type, Scope, AllowClobber, SkipPublisherCheck, InstallUpdate, NoPathUpdate, Filter, Tag, Includes, DscResource, RoleCapability, Command, PublishLocatio...
    Programs 3.0.0.0 IncludeWindowsInstaller, IncludeSystemComponent



    PS C:\WINDOWS\system32> $PSVersionTable

    Name Value
    ---- -----
    PSVersion 5.1.14393.4402
    PSEdition Desktop
    PSCompatibleVersions {1.0, 2.0, 3.0, 4.0...}
    BuildVersion 10.0.14393.4402
    CLRVersion 4.0.30319.42000
    WSManStackVersion 3.0
    PSRemotingProtocolVersion 2.3
    SerializationVersion 1.1.0.1

    Thanks for any help.

    -- webrunner

    • This topic was modified 11 months, 3 weeks ago by  webrunner. Reason: Added PS version info
    Attachments:
    You must be logged in to view attached files.

    -------------------
    A SQL query walks into a bar and sees two tables. He walks up to them and asks, "Can I join you?"
    Ref.: http://tkyte.blogspot.com/2009/02/sql-joke.html

  • it is internet access issue - you may need to speak with your network/system admins to allow that server the required access to the internet to do this install.

    It may also be that you need to specify a proxy on the install-module - see https://docs.microsoft.com/en-us/powershell/module/powershellget/install-module?view=powershell-7.1

    you may also ask them if there is a local (company) repository that should be used instead of the default internet one - and if so this can be registered on this computer to allow you to install the module - in this case someone will also need to "deploy" the module to that internal repository

     

    and if nothing else works you can do the manual install - not always advisable. https://docs.microsoft.com/en-us/powershell/scripting/gallery/how-to/working-with-packages/manual-download?view=powershell-7.1

  • Hi Frederico,

    Thanks for this info!

    -- webrunner

    -------------------
    A SQL query walks into a bar and sees two tables. He walks up to them and asks, "Can I join you?"
    Ref.: http://tkyte.blogspot.com/2009/02/sql-joke.html

  • PS I think I got the specific solution for my issue. It was sort of internet related, but specifically I needed to set TLS 1.2.

    Thanks again!

    https://answers.microsoft.com/en-us/windows/forum/windows_7-performance/trying-to-install-program-using-powershell-and/4c3ac2b2-ebd4-4b2a-a673-e283827da143

    "

    Niels Weistra

    Replied on May 15, 2018

    Well, I had the same problem. Set my Powershell to TLS 1.2 and it worked for me.

     

    To test this :

    1. Open Powershell (As Admin)

    2. [Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12

    3. Try it again!

     

    Niels Weistra"

     

     

     

    -- webrunner

    -------------------
    A SQL query walks into a bar and sees two tables. He walks up to them and asks, "Can I join you?"
    Ref.: http://tkyte.blogspot.com/2009/02/sql-joke.html

Viewing 4 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply