Can't Open Existing or Create New SSIS projects

  • troy.balmforth

    SSC Journeyman

    Points: 87

    Hi All

    I am currently having a problem opening an existing SSIS project I have been working on for the last few weeks. I am using Visual Studio Team Suite 2005 SP1/SQL Server 2005 SP2 on Vista Enterprise SP1.

    The error I get is:

    TITLE: Microsoft Visual Studio

    ------------------------------

    There were errors while the package was being loaded.

    The package might be corrupted.

    See the Error List for details.

    Error loading BUAR_Extract_Belise.dstx: Unable to instantiate XML DOM document, please verify that MSXML binaries are properly installed and registered.

    I have also tried creating a new SSIS project to verify if my project is indeed corrupt. This gives the error:

    - Failed to save package file "C:\Users...." with error 0x80040155 "Interface not registered"

    I have searched the Web and found the solution to re-register MSXML3/MSXML6 but this has not worked although the messagebox says it was successful.

    I have just finished uninstalling/re-installing SQL Server 2005/VSTS 2005 and the problem is still persisting.

    Can anyone please shed some light on this for me.

    Thanks,

    Troy

  • doganilhami

    Valued Member

    Points: 57

    Hii You must registered folloving two dll

    regsvr32 msxml3.dll

    regsvr32 msxml6.dll

  • Scott Thornton-407727

    SSCrazy

    Points: 2271

    Hi,

    I have been getting the same error for a while now. I expect it may have had something to do with a windows update that was rolled out by our support people ( I am on a corporate PC)

    Running the regsvr commands seem to help.

  • mrgecoutu

    SSC Journeyman

    Points: 77

    This also fixed the same problem when trying to load SSIS packages in Integration Services in Visual Studio 2008.

    Thank you for your suggestion!!

  • rst111973

    SSC Rookie

    Points: 33

    Add/Remove programs and repair

  • srinivasvuradi

    Valued Member

    Points: 69

    Running these commands solved my problem

    regsvr32 msxml3.dll

    regvr32 msxml6.dll:-)

  • PRASOON.84

    Old Hand

    Points: 369

    Thank You very much...

    Running these commands solved my problem... :w00t:

    regsvr32 msxml3.dll

    regvr32 msxml6.dll

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic. Login to reply