Cannot generate SSPI context

  • One of my coworkers has been getting this error when he tries to log into our SQL Server 2005 instances from home. What we have found strange is that he can connect to any of the instances using his laptop when he's plugged in at the office, but he gets the "Cannot generate SSPI context" error when he tries to connect from home. We have Juniper for the VPN and he can access other network resources when he's connected. When I connect from my house and try, I have no problems connecting to the SQL Server instances.

    I've tried checking profiler and logs when he's made connection attempts, but I don't see anything. We've been digging around at this for several days now and tried checking quite a few things. His login looks alright, we've tried pinging the server, flushing the DNS on his machine. Just can't figure it out.

    Any ideas?

  • Unfortunately there can be many causes for this error, its one of those that makes ny heart sink when I see it. What I would say is approach this from the AD end. Look for ANY discrepancies between this guys set up in AD and everyone elses. If there are any, amend them.

    ---------------------------------------------------------------------

  • if he's going under windows authentication than it probably means he can't contact a domain controller to authenticate. have him use a sql login

  • I was thinking it might be an issue in AD. We'll have to corner our network admin for some assistance next week. But thank you for the suggestion to set up a SQL login. I think that would be a workable solution until we can get the credentials sorted out.

  • vpn can be a bit flaky with a home computer and having the right DNS settings

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic. Login to reply