Can you toggle visibility of a column as well as a row in a table?

  • I'm having great difficulty getting the toggling to work! I've got a table with a detail row, a group row and a header row. What I want to do is to toggle on a group field hiding and displaying the detail row, but also hide or display specific columns as well as they're not applicable when the detail row is hidden. Is this possible? I've set the initial visibility to hidden in the Details Grouping tab and set the visibility can be toggled by another report item to be the first field in the group row. When I then highlight a column in the table to hide this according to the same toggle item, right click and select properties and set the toggle item to be the first field in the group row as above, I get the following error:

    [rsInvalidToggleItem] The table ‘table1’ has ‘CRSRefHeader’ as a toggle item. Toggle items must be text boxes that share the same scope as the hidden item or are in a scope that contains the hidden item, and cannot be contained within the current report item unless current grouping scope has a Parent.

    This sort of makes sense, but I don't know how to fix it! Any ideas?

  • m having d same problem 🙁 . are you able to get rid of this. if s give me your solution

    Amar

  • I didn't work out a way of toggling both I'm afraid. Toggling views can be very troublesome I find. Something I've found recently is, if you've set up a report using the wizard and it's embedded a table within a list then this can cause havoc when you're trying to establish why something won't toggle. The way I fixed that was to move the table outside the list and deleting the list (if you want to know why I'd done this, it was by accident when initially requesting the type of grouping I wanted).

  • You don't really need the wizard to put a table control in place. While it's a handy feature, you'll likely learn more if you try to put a table in entirely on your own. It will force you to take EVERYTHING into consideration, and just having to go through that thought process can be quite helpful.

    As to hiding a column, you might want to consider having your headings for your detail row separate from your headings for your group row. I have a purchase order report that works that way, and has at least 2 separate tables in it. With separate tables, you just point both at the same dataset, and use different grouping mechanisms, and then you get to even have differeing column widths. Try it...

    Steve

    (aka smunson)

    :):):)

    Steve?(aka sgmunson)?:) 🙂 :)?
    Health & Nutrition
    Make Guaranteed Income

  • I agree, but it's normally the lazy option! You do have more control over it if you set it all up yourself too.

  • I don't know about how things go for you, but where I come from, lazy options don't generally produce good results without a considerable quantity of dumb luck, and I'm neither dumb nor lucky... 😀

    Steve

    (aka smunson)

    :):):)

    martin.griffiths (7/30/2008)


    I agree, but it's normally the lazy option! You do have more control over it if you set it all up yourself too.

    Steve?(aka sgmunson)?:) 🙂 :)?
    Health & Nutrition
    Make Guaranteed Income

  • You make both the column and the group toggled by your toggle item. Or you

    make them both dependent on a paramter value.

    simply go into the detail group and point out to the group

  • Hi

    I have this same problem

    the above solution doesnt work, it is what I have tried and where i get the error (unless im not understanding)

    I have built the report without the wizard and have added a column that I only want to show on a toggle.

    I can make the detail row visible or not on the toggle but not the header

    can anyone help?

    Thanks in advance

  • I haven't tried this, but try the solution provided here:

    http://www.theruntime.com/blogs/thomasswilliams/archive/2008/09/29/hiding-and-showing-columns-based-on-a-parameter-in-reporting.aspx

    jacksoncc

  • I had this problem until about 45 seconds ago.

    Turns out I had a superfluous group on the row level. If you're reading this, take the time to make sure this isn't the case for you.

    All I had to do was right click on the superfluous Row Group and "Delete Group Only" (not the rows/cols associated with it)

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic. Login to reply