can I get SQL Server Management Studio 2005 Express to connect to SQL Server 2008 Express databases

  • Could anyone throw somelight on , SQL Server Management Studio 2005 Express can connect to SQL Server 2008 Express databases?

  • Deepak Sahu (1/14/2011)


    Could anyone throw somelight on , SQL Server Management Studio 2005 Express can connect to SQL Server 2008 Express databases?

    I believe it does - as long as you have applied the latest service packs.

    But, I have to ask why you would be concerned about that. Upgrade the client tools to the 2008 version (they are free) and use the 2008 tools to access the 2005 instances.

    If you are using the Advanced Features, then you should install both clients side-by-side (I think that is possible for Express, but not sure).

    And finally, if you have a licensed version of SQL Server 2008 that you connect to then you can install the full client tools. Those tools can be used to manage Express editions also. If you don't have a licensed version, it might be worth the cost to purchase the Developer Edition (~$50) which would give you the full version client tools.

    Jeffrey Williams
    Problems are opportunities brilliantly disguised as insurmountable obstacles.

    How to post questions to get better answers faster
    Managing Transaction Logs

  • Deepak Sahu (1/14/2011)


    Could anyone throw somelight on , SQL Server Management Studio 2005 Express can connect to SQL Server 2008 Express databases?

    The straight forward answer is no unless you upgrade your sql server 2005 Express client tools to sql server 2005.

    So for this you need to download SSME for sql server 2008 this will work for you..

  • Deepak Sahu (1/14/2011)


    Could anyone throw somelight on , SQL Server Management Studio 2005 Express can connect to SQL Server 2008 Express databases?

    The straight forward answer is no unless you upgrade your sql server 2005 Express client tools to sql server 2008.

    So for this you need to download SSME for sql server 2008 this will work for you..

    Note: The older version of Management tools can be used to connect the same or lower version of databases only..

    I hope you got your answer..

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic. Login to reply