BRKR TASK consuming large amount of CPU, but Service Broker is not enabled

  • shadow66

    Say Hey Kid

    Points: 664

    I’m seeing a spid on one of our boxes that says “BRKR TASK” and is consuming a large amount of CPU time, and is doing no Read or Write activity. However, Service Broker is NOT enabled on the box, and there are no endpoints set up on the box either. I’d like to kill the spid, but do not know enough about this to do so.

    The Login Time is 6/26/09 11:23:14 PM, and Last Batch time is the same - 6/26/09 11:23:14 PM. Can I safely kill this or what should I do??

    Many thanks!

  • RBarryYoung

    SSC Guru

    Points: 143327

    How do you know it isn't enabled. Lots of SQL 2005 features use Service Broker under the hood.

    [font="Times New Roman"]-- RBarryYoung[/font], [font="Times New Roman"] (302)375-0451[/font] blog: MovingSQL.com, Twitter: @RBarryYoung[font="Arial Black"]
    Proactive Performance Solutions, Inc.
    [/font]
    [font="Verdana"] "Performance is our middle name."[/font]

  • Gail Shaw

    SSC Guru

    Points: 1004424

    You can't kill system spids. The BRKR TASK sessions on my SQL box are sessions 10, 15 and 16. All system processes.

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • shadow66

    Say Hey Kid

    Points: 664

    Good question - but I assume that since there are no endpoints set up that Service Broker would not work. This is why I am asking this question - I would appreciate any help or insight into this issue.

  • RBarryYoung

    SSC Guru

    Points: 143327

    Well, DB Mirroring, DB Mail and Event Notifications all use Service Broker, so if you're using any of them, then you've got Service Broker running.

    I'll try to lookup how you can check for this later on (heading out the door soon...).

    [font="Times New Roman"]-- RBarryYoung[/font], [font="Times New Roman"] (302)375-0451[/font] blog: MovingSQL.com, Twitter: @RBarryYoung[font="Arial Black"]
    Proactive Performance Solutions, Inc.
    [/font]
    [font="Verdana"] "Performance is our middle name."[/font]

  • EdVassie

    SSC Guru

    Points: 60154

    When you enable Service Broker you are enabling it for User processes. The End Points you set up are User end points. It is always enabled for System processes and the System end points are not shown to mere humans.

    The same concept applies to CLR. Enabling CLR means enabling it for User processes. Many system processes use CLR and the use of CLR for these cannot be turned off or on. (OK, the SQL authors probably have a way of turning service Broker or CLR off for system processes but the rest of us do not.)

    Original author: SQL Server FineBuild[/url] 1-click install and best practice configuration of SQL Server 2017 2016, 2014, 2012, 2008 R2, 2008 and 2005. 14 Mar 2017: now over 40,000 downloads.Disclaimer: All information provided is a personal opinion that may not match reality.Quote: When I give food to the poor they call me a saint. When I ask why they are poor they call me a communist. - Archbishop Hélder Câmara

  • shadow66

    Say Hey Kid

    Points: 664

    We do have mirroring running. I see the endpoints for mirroring, but just cannot figure out why, all of a sudden, CPU is spiking. A little history - on June 26, we added more memory to our production server and this BRKR TASK is showing as taking a ton of CPU since then. Before that, CPU was averaging 40-50%, and is now consistently 90+%. I'm soooo confused!!!

  • Steve Jones - SSC Editor

    SSC Guru

    Points: 714080

    I would bet something else has changed. If you added more memory, you might have people running queries that they didn't run before, or perhaps trying reports that used to time out.

    It could be something with mirroring, and I would look there as well. Is your mirror performing the same?

  • shadow66

    Say Hey Kid

    Points: 664

    Mirroring is performing the same. The memory upgrade has done wonders for performance actually. The CPU spike is the mystery --- I'm using Spotlight for SQL Server, and just watching CPU hover at 90+. The process using the CPU is this BRKR TASK, with CPU at 5,950,000, logical reads at 206 (has never changed) and zero reads and zero writes. The Last Wait Type is BROKER_TASK_STOP.

    Aside from that, nothing else has changed. All of our reporting/queries are done on the mirror with snapshots so nothing but the application touches production.

  • Sudhakar-339037

    SSC Veteran

    Points: 238

    We have the same problem. The BRKR task shows up high cpu usage. No changes made to the server. But we do use lot of db mail and database mirroring. they appear to be fine. But CPU continously at 100%.

    Any clue? Please help.

    /M

    thks,
    //S

  • Des_

    SSC Rookie

    Points: 34

    I encountered the same problem with our test environment and chose to reboot the server than trying to kill a system process. 
    Than resolved the problem.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic. Login to reply