asynchronous_file_target access denied error

  • maroon-78

    Ten Centuries

    Points: 1014

    I am working thru the extended events and I am trying to set the output to a file using asynchronous_file_target. I am getting an access denied error from the OS. The folder that I am trying to write to exists and I am the admin on this system. Is there a configuration option that I need to set? Or do I need to grant the user that is running the sql server service has write access to the target drive? I've tried searching and I'm not getting any good hits. Thanks in advance.

  • Evil Kraig F

    SSC Guru

    Points: 100851

    jberg-604007 (9/25/2012)


    I am working thru the extended events and I am trying to set the output to a file using asynchronous_file_target. I am getting an access denied error from the OS. The folder that I am trying to write to exists and I am the admin on this system. Is there a configuration option that I need to set? Or do I need to grant the user that is running the sql server service has write access to the target drive? I've tried searching and I'm not getting any good hits. Thanks in advance.

    There's two users you'll need to check here. First, yes, the SQL Server service is the one that will definately need access to the filesystem for the file. Next, you'll also want to check the xp_cmdshell proxy and make sure it's not different. I don't remember if extended events relies on that user directly or not but if you *do* have a proxy setup make sure they have access as well just to remove the possible headaches.


    - Craig Farrell

    Never stop learning, even if it hurts. Ego bruises are practically mandatory as you learn unless you've never risked enough to make a mistake.

    For better assistance in answering your questions[/url] | Forum Netiquette
    For index/tuning help, follow these directions.[/url] |Tally Tables[/url]

    Twitter: @AnyWayDBA

  • maroon-78

    Ten Centuries

    Points: 1014

    Thanks Craig!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic. Login to reply