Ask SSC TLS Error

  • anthony.green

    SSC Guru

    Points: 112484

    Posted also over on AskSSC but posting here in case people can't get to the site due to this.

    https://ask.sqlservercentral.com/questions/156338/tls10-tls-11-error-when-browsing-from-secured-hard.html

     

    Getting an issue when browsing ASK from a CIS hardened desktop with the latest version of Edge or Chrome. This is due to Ask using TLS1.0 or TLS.1.1 which it will not support any more and wants Ask to use TLS1.2 or later.

    Any plans to upgrade to latest versions of TLS?

    "Your connection isn't secure

    This site uses an outdated security configuration that might expose your personal information when it's sent to this site (for example, passwords, messages, or credit cards).

    NET:ERR_SSL_OBSOLETE_VERSION

    The connection used to load this site is TLS 1.0 or TLS 1.1, which is outdated and will be turned off in the future. When these are turned off, you wont be able to load the site. The server should use TLS 1.2 or later"

    Pressing the continue button results in a round trip back to the error as the hardened browser wants TLS1.2 and wont continue.

  • Steve Jones - SSC Editor

    SSC Guru

    Points: 720484

    Ask.ssc.com is hosted, and we've had a ticket in for awhile to upgrade. They are working on this, but going slow as they support a number of different SO/SE style sites and need to be sure everyone gets moved at the same time.

    You can bypass this and trust the site with most browsers, but we do agree this is something that needs to be fixed ASAP.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic. Login to reply